Thread (11 messages) flat view 11 messages, 2 authors, 2016-06-15

Re: [PATCH 0/3] Call builtin functions directly, was Re: [PATCH] transport.c: call dash-less form of receive-pack and upload-pack on remote

From: Johannes Schindelin <hidden>
Date: 2016-06-15 22:43:55

Hi,

On Sat, 1 Dec 2007, Junio C Hamano wrote:
Johannes Schindelin [off-list ref] writes:
quoted
Okay, I bit the apple and tried to move the builtins into the library, 
and rename handle_internal_command into execv_git_builtin(), moving it 
into exec-cmd.c.

Big mistake.
I really feel this should not go in.
Hmm.

My rationale was not only avoiding an exec() (which I would find worth it 
on its own), but because this would be a non-verbal step towards 
libification.

Ciao,
Dscho
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help