Re: [PATCH 1/3] git-bisect: war on "sed"
From: Andreas Ericsson <hidden>
Date: 2016-06-15 22:43:51
Miles Bader wrote:
Wincent Colaiuta [off-list ref] writes:quoted
the shorter form without sed is arguably more readable: - echo "$head" | sed 's#^refs/heads/##' >"$GIT_DIR/head-name" + echo "${head#refs/heads/}" >"$GIT_DIR/head-name"Er, I suppose -- if you are acquainted with that particular shell variable syntax (I suspect knowledge of sed is far more widespread). [personally, I know that syntax has something to do with replacing something with something else, but really haven't much clue other than that, and I always _thought_ it was bash-specific and so avoided using any of that stuff.]
It says "remove refs/heads/ from the beginning of the string pointed to by $head". It's not a bashism. Some extensions to that syntax are though (I think). If you want to be sure of portability, use sed instead. git uses this syntax often enough that it's worth using everywhere, but usually only in porcelain commands which one can relatively safely assume are run on at least decently up-to-date developer workstations. You'll note that stuff that absolutely *has* to reside server-side are entirely in C. -- Andreas Ericsson andreas.ericsson@op5.se OP5 AB www.op5.se Tel: +46 8-230225 Fax: +46 8-230231