What's in git.git (stable)
From: Junio C Hamano <hidden>
Date: 2016-06-15 22:43:46
* The 'maint' branch has these fixes since the last announcement.
Brad King (1):
cvsexportcommit: fix for commits that do not have parents
Jakub Narebski (1):
gitweb: Update config file example for snapshot feature in
gitweb/INSTALL
Jonas Fonseca (1):
Remove escaping of '|' in manpage option sections
Jonathan del Strother (1):
Fixing path quoting in git-rebase
Kristian Høgsberg (1):
Remove unecessary hard-coding of EDITOR=':' VISUAL=':' in some test
suites.
Ralf Wildenhues (1):
git-clone.txt: Improve --depth description.
Sergei Organov (3):
git-filter-branch.txt: fix a typo.
git-format-patch.txt: fix explanation of an example.
Documentation: quote commit messages consistently.
----------------------------------------------------------------
* The 'master' branch has these since the last announcement
in addition to the above. Notable topics are:
- fork-exec removal from MinGW work.
- the first batch of parse-options.
- terse progress display.
Short log follows.
Alex Riesen (2):
Rework make_usage to print the usage message immediately
Do no colorify test output if stdout is not a terminal
Blake Ramsdell (1):
transport.c: squelch a gcc 4.0.1 complaint about an uninitialized
variable
Emil Medve (1):
Fixed a command line option type for builtin-fsck.c
Gerrit Pape (1):
git-diff.txt: add section "output format" describing the diff
formats
James Bowes (1):
gc: use parse_options
Johannes Schindelin (2):
Add tests for parse-options.c
parse-options: Allow abbreviated options when unambiguous
Johannes Sixt (14):
Change git_connect() to return a struct child_process instead of a
pid_t.
Use start_command() in git_connect() instead of explicit fork/exec.
Use start_command() to run content filters instead of explicit
fork/exec.
Use run_command() to spawn external diff programs instead of
fork/exec.
Use start_comand() in builtin-fetch-pack.c instead of explicit
fork/exec.
Have start_command() create a pipe to read the stderr of the child.
upload-pack: Use start_command() to run pack-objects in
create_pack_file().
Add infrastructure to run a function asynchronously.
Use the asyncronous function infrastructure in
builtin-fetch-pack.c.
upload-pack: Move the revision walker into a separate function.
upload-pack: Run rev-list in an asynchronous function.
t0021-conversion.sh: Test that the clean filter really cleans
content.
Avoid a dup2(2) in apply_filter() - start_command() can do it for
us.
Use the asyncronous function infrastructure to run the content
filter.
Jonas Fonseca (1):
Update manpages to reflect new short and long option aliases
Kristian Høgsberg (5):
Enable wt-status output to a given FILE pointer.
Enable wt-status to run against non-standard index file.
Introduce entry point add_interactive and add_files_to_cache
Export rerere() and launch_editor().
Port builtin-add.c to use the new option parser.
Nicolas Pitre (16):
more compact progress display
cope with multiple line breaks within sideband progress messages
pack-objects: no delta possible with only one object in the list
pack-objects.c: fix some global variable abuse and memory leaks
fix const issues with some functions
fix for more minor memory leaks
prune-packed: don't call display_progress() for every file
make struct progress an opaque type
relax usage of the progress API
add throughput to progress display
add throughput display to index-pack
add some copyright notice to the progress display code
add throughput display to git-push
return the prune-packed progress display to the inner loop
make sure throughput display gets updated even if progress doesn't
move
Show total transferred as part of throughput progress
Pierre Habouzit (17):
Add a simple option parser.
parse-options: be able to generate usages automatically
parse-options: make some arguments optional, add callbacks.
Add shortcuts for very often used options.
parse-options: allow callbacks to take no arguments at all.
Make builtin-rm.c use parse_options.
Make builtin-mv.c use parse-options
Make builtin-branch.c use parse_options.
Make builtin-describe.c use parse_options
Make builtin-revert.c use parse_options.
Make builtin-update-ref.c use parse_options
Make builtin-symbolic-ref.c use parse_options.
Make builtin-for-each-ref.c use parse-opts.
Make builtin-fsck.c use parse_options.
Make builtin-count-objects.c use parse_options.
Make builtin-name-rev.c use parse_options.
Make builtin-pack-refs.c use parse_options.
Scott R Parish (7):
"git" returns 1; "git help" and "git help -a" return 0
remove unused/unneeded "pattern" argument of list_commands
"current_exec_path" is a misleading name, use "argv_exec_path"
list_commands(): simplify code by using chdir()
use only the $PATH for exec'ing git commands
include $PATH in generating list of commands for "help -a"
shell should call the new setup_path() to setup $PATH
Shawn O. Pearce (3):
Change 'Deltifying objects' to 'Compressing objects'
Teach prune-packed to use the standard progress meter
Stop displaying "Pack pack-$ID created." during git-gc
Steffen Prohaska (3):
mergetool: use path to mergetool in config var
mergetool.<tool>.path
mergetool: add support for ECMerge
mergetool: avoid misleading message "Resetting to default..."