On Sat, Nov 03, 2007 at 12:36:36PM +0000, Johannes Schindelin wrote:
Hi,
On Sat, 3 Nov 2007, Mike Hommey wrote:
quoted
On Sat, Nov 03, 2007 at 11:54:38AM +0000, Johannes Schindelin wrote:
quoted
Why not teach write_annotations() (or write_tag_body() like I would prefer
it to be called) to grok a null_sha1? It's not like we care for
performance here, but rather for readability and ease of use.
By the way, I think it would be much better if this function was made
more generic and would not write, but return an strbuf containing the
object body. It could also be used by e.g. git-commit --amend.
What would be the best suited place for such a function ?
editor.c, I'd say.
On which topic is this ?
Mike