[PATCH 5/5] Use 'unsigned:1' when we mean boolean options
From: Shawn O. Pearce <hidden>
Date: 2016-06-15 22:43:35
Subsystem:
the rest · Maintainer:
Linus Torvalds
From: Shawn O. Pearce <hidden>
Date: 2016-06-15 22:43:35
Subsystem:
the rest · Maintainer:
Linus Torvalds
These options are all strictly boolean (true/false). Its easier to document this implicitly by making their storage type a single bit. There is no compelling memory space reduction reason for this change, it just makes the structure definition slightly more readable. Signed-off-by: Shawn O. Pearce <redacted> --- fetch-pack.h | 12 ++++++------ 1 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/fetch-pack.h b/fetch-pack.h
index cdcd84f..ad13076 100644
--- a/fetch-pack.h
+++ b/fetch-pack.h@@ -4,14 +4,14 @@ struct fetch_pack_args { const char *uploadpack; - int quiet; - int keep_pack; int unpacklimit; - int use_thin_pack; - int fetch_all; - int verbose; int depth; - int no_progress; + unsigned quiet:1, + keep_pack:1, + use_thin_pack:1, + fetch_all:1, + verbose:1, + no_progress:1; }; void setup_fetch_pack(struct fetch_pack_args *args);
--
1.5.3.1.1000.g7319b