Brett Schwarz [off-list ref] wrote:
This is a good idea. However, I assume the _ proc is just sugar. It
might be better to follow a more "standard" way for this, and just
import the msgcat namespace, and then you can just use [mc]. For
example:
package require msgcat
namespace import ::msgcat::*
.
.
.
.mbar add cascade -label [mc Repository] -menu .mbar.repository
Not just better, I'd prefer it. The proc name "_" is cute but
is just too darn short. I would much prefer to use "mc" and just
say that "mc" in all of git-gui's namespaces is reserved for the
message catalog, much as "cb" is already reserved for setting up
callbacks for Tcl/Tk event handlers.
--
Shawn.