Re: [PATCH 0/6] gitweb: 'commitdiff' view improvements
From: Junio C Hamano <hidden>
Date: 2016-06-15 22:43:15
Overall it makes the view of merge commit much more pleasant. Good job. [1/6] Jakub Narebski [off-list ref] writes:
To save space links are shown as "n", where "n" is number of a parent, and not as for example shortened (to 7 characters) sha1 of a parent commit. To make it easier to discover what links is for, each link has 'title' attribute explaining the link.
Nice; this is a good way to give "diff $it^$n $it". The 'title' does not feel that useful but it does not add much to the weight of the payload so it probably is Ok.
Example output:
1 2 3
Makefile patch | diff1 | diff2 | diff3 | blob | history
cache.h patch | diff1 | diff2 | diff3 | blob | historyIt is now tempting to change diff[1234...] for each path to "diff", isn't it? [3/6] Jakub Narebski [off-list ref] writes:
This commit makes git_patchset_body easier to read, and reduces level of nesting and indent level. It adds more lines that it removes because of extra parameter passing in subroutines, and subroutine calls in git_patchset_body. Also because there are few added comments.
Very nice. That gigantic loop in patchset_body has always been an eyesore. The main loop is much easier to follow now.