"Michael S. Tsirkin" [off-list ref] writes:
quoted
Quoting Alex Riesen [off-list ref]:
Subject: Re: [PATCHv2] connect: display connection progress
On 5/10/07, Michael S. Tsirkin [off-list ref] wrote:
quoted
-static int git_tcp_connect_sock(char *host)
+static int git_tcp_connect_sock(char *host, int flags)
There is only one bit of flags ever used. What are the others for?
Hmm, I thought it's easier to read
git_tcp_connect_sock(host, NET_QUIET)
than
git_tcp_connect_sock(host, 1)
but maybe that's overdesign.
quoted
Why use negative logic?
What was wrong with plain "int verbose"?
I want the default to report connections, and -q
to silence them. Maybe "int quiet"?
I would really feel this extra verbosity should not be the
default. Thanks.