Re: [PATCH] Rename warn() to warning() to fix symbol conflicts on BSD and Mac OS

3 messages, 3 authors, 2016-06-15 · open the first message on its own page

Re: [PATCH] Rename warn() to warning() to fix symbol conflicts on BSD and Mac OS

From: Junio C Hamano <hidden>
Date: 2016-06-15 22:43:02

Theodore Ts'o [off-list ref] writes:
This fixes a problem reported by Randal Schwartz:
quoted
I finally tracked down all the (albeit inconsequential) errors I was getting
on both OpenBSD and OSX.  It's the warn() function in usage.c.  There's
warn(3) in BSD-style distros.  It'd take a "great rename" to change it, but if
someone with better C skills than I have could do that, my linker and I would
appreciate it.
It was annoying to me, too, when I was doing some mergetool testing on
Mac OS X, so here's a fix.
I'd take this for now, but I wonder where we should stop.  If
somebody exports error() or die(), would we end up renaming them
to git_error() and git_die()?

Re: [PATCH] Rename warn() to warning() to fix symbol conflicts on BSD and Mac OS

From: Johannes Schindelin <hidden>
Date: 2016-06-15 22:43:02

Hi,

On Sat, 31 Mar 2007, Junio C Hamano wrote:
Theodore Ts'o [off-list ref] writes:
quoted
This fixes a problem reported by Randal Schwartz:
quoted
I finally tracked down all the (albeit inconsequential) errors I was getting
on both OpenBSD and OSX.  It's the warn() function in usage.c.  There's
warn(3) in BSD-style distros.  It'd take a "great rename" to change it, but if
someone with better C skills than I have could do that, my linker and I would
appreciate it.
It was annoying to me, too, when I was doing some mergetool testing on
Mac OS X, so here's a fix.
I'd take this for now, but I wonder where we should stop.  If
somebody exports error() or die(), would we end up renaming them
to git_error() and git_die()?
Libification, here we come ;-)

Ciao,
Dscho

Re: [PATCH] Rename warn() to warning() to fix symbol conflicts on BSD and Mac OS

From: Alex Riesen <hidden>
Date: 2016-06-15 22:43:02

Junio C Hamano, Sat, Mar 31, 2007 10:15:31 +0200:
quoted
quoted
I finally tracked down all the (albeit inconsequential) errors I was getting
on both OpenBSD and OSX.  It's the warn() function in usage.c.  There's
warn(3) in BSD-style distros.  It'd take a "great rename" to change it, but if
someone with better C skills than I have could do that, my linker and I would
appreciate it.
It was annoying to me, too, when I was doing some mergetool testing on
Mac OS X, so here's a fix.
I'd take this for now, but I wonder where we should stop. 
Glibc also has warn(3) - see err.h for example.
(why is it part of libc, I wonder...)
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help