Andy Parkins [off-list ref] writes:
On Thursday 2007 March 01 07:18, Junio C Hamano wrote:
quoted
[pathattr "text/plain"]
conv_i = crlf
path = "*.txt"
path = "*.c"
path = "*.h"
Can I suggest that "crlf" is not the right name for something like this? What
you actually want is to say
conv_i = convert_from_local_lineendings
conv_o = convert_to_local_lineendings
The sample traits' value "crlf" is probably a misnomer. As you
noticed, they are to _force_ the conversion. You can add one
that honors core.autocrlf (which would be set to true on Windows
and to false on UNIX).
conv_i = eol_to_lf
conv_o = eol_to_local
Probably.
quoted hunk
--- Wild rantings start here, ignore at will ---
Will ignore for now, since I have more interesting patches
coming for your enjoyment ;-).