Johannes Schindelin [off-list ref] writes:
This speeds up the case when you run git-status, having an untracked
subdirectory containing huge amounts of files.
Signed-off-by: Johannes Schindelin <redacted>
---
On Thu, 28 Sep 2006, Johannes Schindelin wrote:
Okay, so no more dir_is_empty(). Instead, read_directory_recursive()
gets a flag. With this flag, "check_only", it exits as soon as it
found valid entries, but does not add any. Way easier.
Yeah, the logic is a lot easier to follow.