Pierre Habouzit [off-list ref] writes:
Allow a form of virtualhosting, when %h format is used.
Signed-off-by: Pierre Habouzit <redacted>
---
This is intended to be a more flexible solution, that also gives virtual
hosting as a bonus.
Nicely done, almost.
Having to have the distinction between %p and %P formats feels
somewhat unwieldy, though. Not that I have a better suggestion.
+int is_base_path_fmt;
+int is_user_path_fmt;
I prefer these to be of type "static int".
Although I am not an authority of variable naming, these sound
funny to me. "is_XXX()" as a function name feels natural,
"is_XXX" as a variable name does not --- it is not clear what
the predicate is talking about.
Maybe "use_fmt_for_base_path" is easier to understand? I dunno.
Or "user_path_is_fmt"? That's more logical but still somewhat
feels funny.