Hi,
On Mon, 12 Jun 2006, Fredrik Kuivinen wrote:
quoted hunk ↗ jump to hunk
diff --git a/blame.c b/blame.c
index 88bfec2..afa22b5 100644
--- a/blame.c
+++ b/blame.c
@@ -20,9 +20,11 @@ #include "xdiff-interface.h"
#define DEBUG 0
-static const char blame_usage[] = "[-c] [-l] [--] file [commit]\n"
+static const char blame_usage[] = "[-c] [-l] [-t] [-S <revs-file>] [--] file [commit]\n"
That is a bit more than the commit message says.
+ " -t, --time Show raw timestamp (Default: off)\n"
+ " -S, --revs-file Use revisions from revs-file instead of calling git-rev-list\n"
I smell white space corruption here.
+ int raw_time)
Just a tiny nit: could you name it "show_raw_time" instead of "raw_time"?
I got confused by that naming into believeing raw_time was actually a
timestamp, not a boolean...
Ciao,
Dscho