- for (i = 0; i < count; i++)
+ for (i = 0; obj_allocs ; i++)
GAAH.
That should obviously be "i < obj_allocs".
That's what I get for editing the patch in-place to remove the optimized
version that I felt wasn't worth worrying about due to being subtle. So
instead I sent out a patch that was not-so-subtly obvious crap!
Sorry about that.
Linus