Re: [RFC] extending git-ls-files --exclude.
From: Junio C Hamano <hidden>
Date: 2016-06-15 22:42:02
Marco Costalba [off-list ref] writes:
Are really necessary to have both --exclude-from=<file> and --exclude-per-directory=<name> ? Peraphs, if the file name of excluded list is the same for each directory, e.g. .gitignore or something similar, instead of --exclude-per-directory we can use a concept of file validity 'scope' and just use --exclude-from=<file>. If entering in a directory <file> is found its contents are appended and removed when leaving directory. A bad analogy can be with the use of recursive Makefile.
Pasky wants to have one of the files in ~/.git-something if I understand correctly. I did not want to remove --exclude-from for that reason.
If we use the 'scope' logic we can just prepend path when adding entries and serach with with FNM_PATHNAME flag.
And I wanted for people's script and existing ignore files to continue to work.
Same comment as above, if prepending path when adding per directory contents we can simplify to always use FNM_PATHNAME flag.
Yes, but that means you need to always prepend the current directory being looked at to get the original behaviour. The way it was originally done without FNM_PATHNAME was far easier to read, at least for me.