Re: [RFC] Renaming environment variables.
From: Junio C Hamano <hidden>
Date: 2016-06-15 22:41:56
quoted
quoted
quoted
quoted
"PB" == Petr Baudis [off-list ref] writes:
PB> Could I please have s/COMMIT_AUTHOR/COMMITTER/ and PB> s/OBJECTS/(OBJDIR|OBJECT_DIR)/? The former sounds much better. The latter how about GIT_OBJECT_DIRECTORY? Not much longer than the original SHA1_FILE_DIRECTORY anyway. PB> (Cogito needs its own git-merge-cache so that the merge goes properly PB> anyway, and it already (or still) carries its Git around, so I think PB> it's not applicable to it. Yes, I want and plan to start publishing the PB> Git changes, I'm already making some steps for that and I hope I have PB> something to show by tomorrow.) Sounds good. BTW, what happened to the plan of merging with my tip you sent a message earlier about? PB> Yes, I think couple of weeks is too long. :-) I'd say one or two PB> releases is enough. I'd leave that to community and Linus to decide when he returns. PB> Pretty please, add copyright notices at the top of files. Thanks for pointing it out.
quoted
+char *gitenv_bc(const char *e) +{ + int first, last; + char *val = getenv(e); + if (val) + /* inefficient. caller should use gitenv() not gitenv_bc() */ + return val;
PB> Can this ever happen? If doing it at all, I'd expect gitenv_bc() to PB> rather freak out and die(), the caller is broken. Point taken. I've pushed out an updated version that addresses all of the above issues to git-jc repository [*1*]. Please take a look. [References] *1* http://members.cox.net/junkio/