Thread (1 message) 1 message, 1 author, 2016-06-15

Re: Misc fixes for git-pasky

From: Petr Baudis <hidden>
Date: 2016-06-15 22:41:52

Dear diary, on Fri, Apr 15, 2005 at 12:37:57AM CEST, I got a letter
where Pavel Roskin [off-list ref] told me that...
Hi, Petr!

The attached patch against current git-pasky does following:
Hum. It does too much at once, that means I cannot apply it easily. :-(
* README: spell checked
Good. :-)
* cache.h: Include unistd.h.  Needed for close() definition.  While
current zlib.h header includes unistd.h, it's not guaranteed to be so in
other zlib versions.
Sounds good.
* read-cache.c: Avoid C++ comments.  C comments are more readable for C
programmers.  Besides, we don't want git to be so unportable that "gcc
-pedantic" cannot compile it.
I don't really care about this too much, although I personally prefer
the old-style comments. // comments are C99 so -pedantic by itself
should have no right to complain about it.
* show-diff.c: Fix handling of more than one option of the command line.
What exactly does it fix? The current code seems fine to my sleepy
brain.
Add new option "-c" to omit checksums for modified files.  Expand help.
How is the -c option useful?

Could you please send your patch with the correct inline settings on the
attachment (or just in the mail body) and signed off?

Thanks,

-- 
				Petr "Pasky" Baudis
Stuff: http://pasky.or.cz/
C++: an octopus made by nailing extra legs onto a dog. -- Steve Taylor
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help