[dpdk-dev] [PATCH v2] app/testpmd: remove unused struct member

Subsystems: the rest

4 messages, 2 authors, 2021-02-22 · open the first message on its own page

[dpdk-dev] [PATCH v2] app/testpmd: remove unused struct member

From: Kathleen Capella <hidden>
Date: 2021-02-09 15:40:39

The tx_queue member of the fwd_lcore struct is unused as it is already
part of the fwd_stream structure. Deleting helps improve code readability.

Signed-off-by: Kathleen Capella <redacted>
Reviewed-by: Honnappa Nagarahalli <redacted>
Acked-by: Thomas Monjalon <redacted>
---
 app/test-pmd/testpmd.h | 1 -
 1 file changed, 1 deletion(-)
diff --git a/app/test-pmd/testpmd.h b/app/test-pmd/testpmd.h
index 5f2316210..f805f1b4d 100644
--- a/app/test-pmd/testpmd.h
+++ b/app/test-pmd/testpmd.h
@@ -247,7 +247,6 @@ struct fwd_lcore {
 	streamid_t stream_idx;   /**< index of 1st stream in "fwd_streams" */
 	streamid_t stream_nb;    /**< number of streams in "fwd_streams" */
 	lcoreid_t  cpuid_idx;    /**< index of logical core in CPU id table */
-	queueid_t  tx_queue;     /**< TX queue to send forwarded packets */
 	volatile char stopped;   /**< stop forwarding when set */
 };
 
-- 
2.17.1

Re: [dpdk-dev] [PATCH v2] app/testpmd: remove unused struct member

From: Kathleen Capella <hidden>
Date: 2021-02-19 17:25:33

The iol-testing warning on this patch seems to be unrelated to the patch. 

On February 9, 2021 10:40 AM, Kathleen Capella wrote
The tx_queue member of the fwd_lcore struct is unused as it is already part of the fwd_stream 
structure. Deleting helps improve code readability.
Signed-off-by: Kathleen Capella <redacted>
Reviewed-by: Honnappa Nagarahalli <redacted>
Acked-by: Thomas Monjalon <redacted>
---
app/test-pmd/testpmd.h | 1 -
1 file changed, 1 deletion(-)
quoted hunk
diff --git a/app/test-pmd/testpmd.h b/app/test-pmd/testpmd.h index 5f2316210..f805f1b4d 100644
--- a/app/test-pmd/testpmd.h
+++ b/app/test-pmd/testpmd.h
@@ -247,7 +247,6 @@ struct fwd_lcore {
	streamid_t stream_idx;   /**< index of 1st stream in "fwd_streams" */
	streamid_t stream_nb;    /**< number of streams in "fwd_streams" */
	lcoreid_t  cpuid_idx;    /**< index of logical core in CPU id table */
-	queueid_t  tx_queue;     /**< TX queue to send forwarded packets */
	volatile char stopped;   /**< stop forwarding when set */
};
 
--
2.17.1

Re: [dpdk-dev] [PATCH v2] app/testpmd: remove unused struct member

From: Ferruh Yigit <hidden>
Date: 2021-02-19 18:50:19

On 2/19/2021 5:25 PM, Kathleen Capella wrote:
The iol-testing warning on this patch seems to be unrelated to the patch.
Yep, it looks unrelated, spdk build is failing, I tried to trigger build again, please check after some time if status changes.
On February 9, 2021 10:40 AM, Kathleen Capella wrote
quoted
The tx_queue member of the fwd_lcore struct is unused as it is already part of the fwd_stream
structure. Deleting helps improve code readability.
quoted
Signed-off-by: Kathleen Capella <redacted>
Reviewed-by: Honnappa Nagarahalli <redacted>
Acked-by: Thomas Monjalon <redacted>
---
app/test-pmd/testpmd.h | 1 -
1 file changed, 1 deletion(-)
quoted
diff --git a/app/test-pmd/testpmd.h b/app/test-pmd/testpmd.h index 5f2316210..f805f1b4d 100644
--- a/app/test-pmd/testpmd.h
+++ b/app/test-pmd/testpmd.h
@@ -247,7 +247,6 @@ struct fwd_lcore {
	streamid_t stream_idx;   /**< index of 1st stream in "fwd_streams" */
	streamid_t stream_nb;    /**< number of streams in "fwd_streams" */
	lcoreid_t  cpuid_idx;    /**< index of logical core in CPU id table */
-	queueid_t  tx_queue;     /**< TX queue to send forwarded packets */
	volatile char stopped;   /**< stop forwarding when set */
};
  
quoted
--
2.17.1

Re: [dpdk-dev] [PATCH v2] app/testpmd: remove unused struct member

From: Ferruh Yigit <hidden>
Date: 2021-02-22 18:20:44

On 2/9/2021 3:40 PM, Kathleen Capella wrote:
The tx_queue member of the fwd_lcore struct is unused as it is already
part of the fwd_stream structure. Deleting helps improve code readability.

Signed-off-by: Kathleen Capella <redacted>
Reviewed-by: Honnappa Nagarahalli <redacted>
Acked-by: Thomas Monjalon <redacted>
Applied to dpdk-next-net/main, thanks.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help