Thread (37 messages) 37 messages, 4 authors, 2021-03-15

Re: [dpdk-dev] [RFC PATCH v2] build: kni cross-compilation support

From: Bruce Richardson <hidden>
Date: 2021-02-05 09:39:05

On Fri, Feb 05, 2021 at 09:26:05AM +0000, Juraj Linkeš wrote:
quoted
-----Original Message-----
From: Bruce Richardson <redacted>
Sent: Thursday, February 4, 2021 6:34 PM
To: Juraj Linkeš <redacted>
Cc: thomas@monjalon.net; Ruifeng.Wang@arm.com;
Honnappa.Nagarahalli@arm.com; jerinjacobk@gmail.com;
hemant.agrawal@nxp.com; ferruh.yigit@intel.com; aboyer@pensando.io;
dev@dpdk.org
Subject: Re: [RFC PATCH v2] build: kni cross-compilation support

On Thu, Feb 04, 2021 at 10:51:41AM +0100, Juraj Linkeš wrote:
quoted
The kni linux module is using a custom target for building, which
doesn't take into account any cross compilation arguments. The
arguments in question are ARCH, CROSS_COMPILE (for gcc, clang) and CC,
LD (for clang). Get those from the cross file and pass them to the
custom target.

The user supplied path may not contain the 'build' directory, such as
when using cross-compiled headers, so only append that in the default
case (when no path is supplied in native builds) and use the
unmodified path from the user otherwise. Also modify the install path
accordingly.
quoted
Signed-off-by: Juraj Linkeš <redacted>
Some comments inline below.
Thanks, these are very helpful.
<snip>
quoted
quoted
+kernel_version = run_command('uname', '-r').stdout().strip()
Rename to "host_kernel_version" and probably should be only queried in the
native build case.
In meson vernicular the host machine is where the binaries will be running, i.e. what we're building for, so this may be a bit confusing - we could name it build_machine_kernel_version.
In any case, I'll move to the the native build if branch. But then maybe we don't need to rename it?
Agreed.
quoted
quoted
+cross_args = []
 # if we are cross-compiling we need kernel_dir specified -if
get_option('kernel_dir') == '' and meson.is_cross_build()
-	error('Need "kernel_dir" option for kmod compilation when cross-
compiling')
quoted
+if meson.is_cross_build()
<snip>
quoted
quoted
 endif
The block for cross-compiling is fairly large and complex, so I'm wondering how
we can simplify things a bit. If we had multiple kernel modules I'd suggest
splitting thing up into a native and cross-build subdirectories to get the build
info, but that seems like overkill here.
This configuration would be the same for all kernel modules (right?), so I'm not sure how the number of kernel modules is relevant here.
If we split it, what would the dir structure look like? Something like this?
kernel/linux/
├── aarch64
├── native
├── kni
├── <other_mods>
Yep, that would be the structure - though perhaps with "cross" rather than
"aarch64" being the alternative to "native".  The reason I felt that the
number of kmods was relevant is that it would be really weird to have 2
subdirectories for infrastructure for a single directory containing one
module - a 200% percent overhead ratio. :-) Therefore, I thinking keeping
it all in one file is best, but we'll see after the next revision how it
looks.
quoted
Instead I wonder if it would work better to
handle all the native case initially in a hopefully simpler "if block" and then do
subdir_done(), leaving everything else to be the cross-compilation recipe and
saving at least one level of indentation.
Wouldn't we need to duplicate the code that does make kernelversion and subdirs the actaul modules?
Definitely yes for the subdir call, but that is only one line now. The
"make kernelversion" call - is that needed in the cross-compile case since
one explicitly has to pass in the kernel directories? My original thinking
was to use it to check for the sources more in the native case where we are
picking up paths automatically. Again, it's only a line or two duplicated.
Alternatively, that check could be moved to the "kni" directory meson.build
file, which would make it common.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help