Re: [dpdk-dev] [PATCH] test/ring: add stress test for ST peek API
From: Honnappa Nagarahalli <hidden>
Date: 2020-07-01 14:05:17
<snip>
quoted
quoted
Subject: [PATCH] test/ring: add stress test for ST peek API Introduce new test case to test ST peek API. Signed-off-by: Konstantin Ananyev <redacted> --- This patch depends on the following patch: "ring: fix error vlaue of tail in the peek API for ST mode" (http://patches.dpdk.org/patch/72374/) to run successfully. app/test/Makefile | 1 + app/test/meson.build | 1 + app/test/test_ring_st_peek_stress.c | 54+++++++++++++++++++++++++++++quoted
quoted
app/test/test_ring_stress.c | 3 ++ app/test/test_ring_stress.h | 1 + 5 files changed, 60 insertions(+) create mode 100644 app/test/test_ring_st_peek_stress.cdiff --git a/app/test/Makefile b/app/test/Makefile index7b96a03a6..37bdaf891 100644--- a/app/test/Makefile +++ b/app/test/Makefile@@ -83,6 +83,7 @@ SRCS-y += test_ring_hts_stress.c SRCS-y +=test_ring_perf.c SRCS-y += test_ring_peek_stress.c SRCS-y += test_ring_rts_stress.c +SRCS-y += test_ring_st_peek_stress.c SRCS-y += test_ring_stress.c SRCS-y += test_pmd_perf.cdiff --git a/app/test/meson.build b/app/test/meson.build index5233ead46..4ec7da6b2 100644--- a/app/test/meson.build +++ b/app/test/meson.build@@ -108,6 +108,7 @@ test_sources = files('commands.c', 'test_ring_peek_stress.c', 'test_ring_perf.c', 'test_ring_rts_stress.c', + 'test_ring_st_peek_stress.c',I think we should rename test_ring_peek_stress.c totest_ring_mpmc_hts_peek_stress.c to be consistent with this? Ok, maybe then: 'test_ring_st_peek_stress.c' and 'test_ring_mt_peek_stress.c' to keep naming convention the same?
Ok, I am fine.
quoted
quoted
'test_ring_stress.c', 'test_rwlock.c', 'test_sched.c',