Thread (25 messages) 25 messages, 6 authors, 2020-07-02

Re: [dpdk-dev] [RFC] add flow action context API

From: Bruce Richardson <hidden>
Date: 2020-06-05 08:30:43

On Thu, Jun 04, 2020 at 07:23:04PM +0200, Thomas Monjalon wrote:
04/06/2020 13:12, Andrey Vesnovaty:
quoted
Thomas Monjalon [off-list ref] wrote:
quoted
20/05/2020 11:18, Andrey Vesnovaty:
We had "create", "destroy", "query", but no "modify" capability.
The new API is adding 2 things in my opinion:
        - shared action object
        - "modify" capability (is "update" a better wording?)
Naming is one of the most challenging parts of this RFC.
Some similarity I have found in existing code is
rte_mtr_policer_actions_update()
Is there any existing code having update/modify semantics?
Except one callback in librte_fib, no DPDK API has "modify" in its name.
You can find the word "update" in the API of multiple DPDK libs.
I would like having the opinion of a native english speaker here.
From a language viewpoint either is fine for conveying what the API does.
In this case "update" would seem to be better for consistency reasons.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help