Re: [dpdk-dev] [PATCH v2] lib: fix unnecessary double negation
From: David Marchand <hidden>
Date: 2020-02-14 16:39:49
From: David Marchand <hidden>
Date: 2020-02-14 16:39:49
On Fri, Feb 14, 2020 at 5:28 PM Ciara Power [off-list ref] wrote:
An equality expression already returns either 0 or 1.
There is no need to use double negation for these cases.
Fixes: ea672a8b1655 ("mbuf: remove the rte_pktmbuf structure")
Fixes: a0fd91cefcc0 ("mempool: rename functions with confusing names")
Cc: stable@dpdk.org
Signed-off-by: Ciara Power <redacted>
Acked-by: Olivier Matz <redacted>
Reviewed-by: Ferruh Yigit <redacted>Applied, thanks. -- David Marchand