Re: [RFC v2 1/5] ether: add flow action to redirect packet in a switch domain
From: Alex Rosenbaum <hidden>
Date: 2017-12-22 22:10:10
From: Alex Rosenbaum <hidden>
Date: 2017-12-22 22:10:10
+Adrien On Fri, Dec 22, 2017 at 10:20 AM, Zhang, Qi Z [off-list ref] wrote:
quoted
On Thu, Dec 21, 2017 at 4:35 AM, Qi Zhang [off-list ref] wrote:quoted
Add action RTE_FLOW_ACTION_TYPE_SWITCH_PORT, it can be used to redirect
quoted
A verbs would be better suited for an ACTION_TYPE. while ".._TYPE_PORT" is a nous. Probably ".._TYPE_REDIRECT" would better fit here.I agree it will be better to use verbs for action, so we can have TYPE_REDIRECT_TO_PORT/VF/PF..., But since we already have ACTION_TYPE_VF, ACTION_TYPE_PF ... Maybe it's better just to follow the same pattern?
hemmm, missed these ACTION_TYPE_VF/PF... Adrien, what do you think about these naming conventions?