Re: [PATCH] eal: added new `rte_lcore_is_service_lcore` API.
From: Pavan Nikhilesh Bhagavatula <hidden>
Date: 2017-09-15 17:38:05
On Fri, Sep 15, 2017 at 05:51:36PM +0200, Thomas Monjalon wrote:
15/09/2017 16:59, Pavan Nikhilesh Bhagavatula:quoted
On Fri, Sep 15, 2017 at 02:44:57PM +0000, Van Haaren, Harry wrote:quoted
quoted
quoted
quoted
quoted
We could also choose to add this function to rte_service.h ?Yes that is an option, and OK with me. @Pavan what do you think of adding it to service.h, implement in .c and addto .map?quoted
The ROLE_SERVICE/ROLE_RTE defines the role of a lcore so it made sense to put it in rte_lcore.h as lcore properties are accessed mostly through this header. I'm fine with adding it to service.h as suggested by Harry. -Pavan*as suggested by Thomas ;) Initially I thought it made more sense in lcore.h too, however the application should only require knowing if core X is a service core if it cares about services / service-cores, hence I'm fine with rte_service.h too. -HarryAgreed, will spin up a v2.The most difficult is to find a good name for this function :)
If not rte_lcore_is_service_core then how about rte_lcore_is_role_service? But this would need a sibling api rte_lcore_is_role_rte (or a better one) which is satisfied by rte_lcore_is_enabled :( IMO when role was limited to RTE & OFF rte_lcore_is_enabled fits now with new role SERVICE it looks out of place cause even service lcores are "enabled". Modifying rte_lcore_is_enabled would be a huge task (API change) as it is used widely in many places. -Pavan