Re: [PATCH 5/6] vhost: add a flag to enable Tx zero copy
From: Thomas Monjalon <hidden>
Date: 2016-09-07 16:00:38
2016-09-06 17:55, Yuanhan Liu:
On Tue, Sep 06, 2016 at 09:00:14AM +0000, Xu, Qian Q wrote:quoted
Just curious about the naming: vhost USER TX Zero copy. In fact, it's Vhost RX zero-copy For virtio, it's Virtio TX zero-copy. So, I wonder why we call it as Vhost TX ZERO-COPY, Any comments?It's just that "Tx zero copy" looks more nature to me (yes, I took the name from the virtio point of view). Besides that, naming it to "vhost Rx zero copy" would be a little weird, based on we have functions like "virtio_dev_rx" in the enqueue path while here we just touch dequeue path. OTOH, I seldome say "vhost-user Tx zero copy"; I normally mention it as "Tx zero copy", without mentioning "vhost-user". For the flag RTE_VHOST_USER_TX_ZERO_COPY, all vhost-user flags start with "RTE_VHOST_USER_" prefix.
I agree that the naming in vhost code is quite confusing. It would be better to define a terminology and stop mixing virtio/vhost directions as well as Rx/Tx and enqueue/dequeue. Or at least, it should be documented.