Thread (10 messages) 10 messages, 4 authors, 2016-02-17

Re: [PATCH] config: add default linux configuration

From: Iremonger, Bernard <hidden>
Date: 2016-02-17 10:42:58

Hi Thomas,
-----Original Message-----
From: Yigit, Ferruh
Sent: Tuesday, February 16, 2016 12:09 PM
To: Thomas Monjalon <redacted>
Cc: dev@dpdk.org; Iremonger, Bernard <redacted>
Subject: Re: [dpdk-dev] [PATCH] config: add default linux configuration

On Tue, Feb 16, 2016 at 12:23:12PM +0100, Thomas Monjalon wrote:
quoted
2016-02-16 11:16, Ferruh Yigit:
quoted
On Thu, Jan 28, 2016 at 02:31:45PM +0000, Bernard Iremonger wrote:
quoted
add config/defconfig_x86_64-default-linuxapp-gcc file.

Signed-off-by: Bernard Iremonger <redacted>
Apart from configuration related discussion, this patch was helpful
for me to notice "default" machine type, and difference between
"native", so I believe it is good to have this as sample config.
The justification is strange. We are not going to have a config file
for every combinations.
Simply I found useful for me and thought others can be useful too, if you
think not useful, that is OK, and yes probably we shouldn't have a sample for
every combination and this patch is not suggesting that.
quoted
Defaulting defconfig files to the native machine natural to me.
No issue on having native machine type, just another defconfig with another
machine type.
The default config is useful when working with VM's, that is why I would like to add it.
I don't think it is necessary to add default configs for all the compilers, one sample should be enough.
quoted
quoted
Also not scope of this patch but I agree on Bruce's comment on
renaming "default" machine type to "generic", I can send a patch for this
if there is a demand.
quoted
default is an Intel core 2. Why generic is a better name?
When you have "x86_64-default-linuxapp-icc", this feels like this is default
configuration for given architecture among others, which will give best
performance (what native suggests) If I would know nothing about DPDK and
see available configs first time, I would pick this one, because this is default
one J.

"generic" stress more that this config supports generic features of different
machine types.

But this is how I feel, as I said I would prefer "generic", but I can survive with
existing one.

Thanks,
Ferruh
Regards,

Bernard.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help