Re: [PATCH v10 2/9] cpuset: Add new v2 cpuset.sched.domain_root flag
From: Peter Zijlstra <peterz@infradead.org>
Date: 2018-06-21 09:27:47
Also in:
linux-doc, lkml
From: Peter Zijlstra <peterz@infradead.org>
Date: 2018-06-21 09:27:47
Also in:
linux-doc, lkml
On Thu, Jun 21, 2018 at 03:58:06PM +0800, Waiman Long wrote:
On 06/20/2018 10:27 PM, Peter Zijlstra wrote:quoted
On Mon, Jun 18, 2018 at 12:14:01PM +0800, Waiman Long wrote:quoted
+ cpuset.sched.domain_rootWhy are we calling this a domain_root and not a partition?A partition can consist of several cgroups in a tree structure. That flag should only be set at the root of a partition. I will change the name to partition_root if you think this name is acceptable.
The flag indicates the 'effective_cpus' things of the current group is a partition. The fact that it can have sub-partitions doesn't really matter does it. Just call it 'partition', leave out the whole root stuff, all of cgroup is hierarchical and you can have sub-groups we don't go around calling everything a root.