On Tue, Jan 17, 2017 at 03:54:11PM -0800, Tejun Heo wrote:
If there's contention on slab_mutex, queueing the per-cache
destruction work item on the system_wq can unnecessarily create and
tie up a lot of kworkers.
Rename memcg_kmem_cache_create_wq to memcg_kmem_cache_wq and make it
global and use that workqueue for the destruction work items too.
While at it, convert the workqueue from an unbound workqueue to a
per-cpu one with concurrency limited to 1. It's generally preferable
to use per-cpu workqueues and concurrency limit of 1 is safe enough.
This is suggested by Joonsoo Kim.
Signed-off-by: Tejun Heo <tj@kernel.org>
Reported-by: Jay Vana <redacted>
Cc: Vladimir Davydov <redacted>
Cc: Christoph Lameter <redacted>
Cc: Pekka Enberg <penberg@kernel.org>
Cc: David Rientjes <rientjes@google.com>
Cc: Joonsoo Kim <redacted>
Cc: Andrew Morton <akpm@linux-foundation.org>
Acked-by: Vladimir Davydov <redacted>
--
To unsubscribe, send a message with 'unsubscribe linux-mm' in
the body to majordomo@kvack.org. For more info on Linux MM,
see: http://www.linux-mm.org/ .
Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>