Re: [PATCH v6 2/2] decrement static keys on real destroy time
From: Andrew Morton <akpm@linux-foundation.org>
Date: 2012-05-23 20:33:56
Also in:
linux-mm, netdev
From: Andrew Morton <akpm@linux-foundation.org>
Date: 2012-05-23 20:33:56
Also in:
linux-mm, netdev
On Wed, 23 May 2012 13:16:36 +0400 Glauber Costa [off-list ref] wrote:
On 05/23/2012 02:46 AM, Andrew Morton wrote:quoted
Here, we're open-coding kinda-test_bit(). Why do that? These flags are modified with set_bit() and friends, so we should read them with the matching test_bit()?My reasoning was to be as cheap as possible, as you noted yourself two paragraphs below.
These aren't on any fast path, are they? Plus: you failed in that objective! The C compiler's internal scalar->bool conversion makes these functions no more efficient than test_bit().
quoted
So here are suggested changes from*some* of the above discussion. Please consider, incorporate, retest and send us a v7?How do you want me to do it? Should I add your patch ontop of mine, and then another one that tweaks whatever else is left, or should I just merge those changes into the patches I have?
A brand new patch, I guess. I can sort out the what-did-he-change view at this end. -- To unsubscribe, send a message with 'unsubscribe linux-mm' in the body to majordomo@kvack.org. For more info on Linux MM, see: http://www.linux-mm.org/ . Fight unfair telecom internet charges in Canada: sign http://stopthemeter.ca/ Don't email: <a href=mailto:"dont@kvack.org"> email@kvack.org </a>