Thread (57 messages) 57 messages, 7 authors, 2021-07-29

Re: [PATCH -tip v8 10/13] x86/kprobes: Push a fake return address at kretprobe_trampoline

From: Ingo Molnar <mingo@kernel.org>
Date: 2021-07-05 08:17:34
Also in: lkml

* Masami Hiramatsu [off-list ref] wrote:
+	/* Replace fake return address with real one. */
+	*frame_pointer = kretprobe_trampoline_handler(regs, frame_pointer);
+	/*
+	 * Move flags to sp so that kretprobe_trapmoline can return
+	 * right after popf.
What is a trapmoline?

Also, in the x86 code we capitalize register and instruction names so that 
they are more distinctive and easier to read in the flow of English text.

Thanks,

	Ingo
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help