page cache · Supported
Maintainers
- M Matthew Wilcox <willy@infradead.org>
- M Jan Kara <jack@suse.cz>
Paths
- F
Documentation/filesystems/locking.rst - F
Documentation/filesystems/vfs.rst - F
include/linux/pagemap.h - F
include/linux/writeback.h - F
include/trace/events/filemap.h - F
include/trace/events/readahead.h - F
include/trace/events/writeback.h - F
mm/filemap.c - F
mm/page-writeback.c - F
mm/readahead.c - F
mm/truncate.c
Last 30 days
Recent patches
Most-recent 27 patches in this subsystem on virtualization, ordered by date desc.
-
COLD23d
REVIEWED: 1 (0M) [PATCH 2/3] blk-cgroup: store blkcg in bio instead of blkg
2026-08-23 · Yu Kuai <yukuai@kernel.org> -
COLD47d
[RFC PATCH v3 2/3] blk-cgroup: store blkcg in bio instead of blkg
2026-08-18 · Yu Kuai <yukuai@kernel.org> -
COLD54d
[RFC PATCH v2 3/4] blk-cgroup: store blkcg in bio instead of blkg
2026-08-11 · Yu Kuai <yukuai@kernel.org> -
STALE61d
[RFC PATCH v1 2/3] blk-cgroup: store blkcg in bio instead of blkg
2026-08-04 · Yu Kuai <yukuai@kernel.org> -
STALE163d
[PATCH RFC v3 01/19] mm: thread user_addr through page allocator for cache-friendly zeroing
2026-04-21 · "Michael S. Tsirkin" <mst@redhat.com> -
STALE173d
Re: [PATCH RFC 3/9] mm: add __GFP_PREZEROED flag and folio_test_clear_prezeroed()
2026-04-13 · "Michael S. Tsirkin" <mst@redhat.com> -
STALE452d
REVIEWED: 6 (4M) [PATCH v2 26/29] mm: rename PAGE_MAPPING_* to FOLIO_MAPPING_*
2025-07-04 · David Hildenbrand <hidden> -
STALE461d
REVIEWED: 4 (4M) [PATCH v1 26/29] mm: rename PAGE_MAPPING_* to FOLIO_MAPPING_*
2025-06-30 · David Hildenbrand <hidden> -
STALE463d
[PATCH RFC 26/29] mm: rename PAGE_MAPPING_* to FOLIO_MAPPING_*
2025-06-18 · David Hildenbrand <hidden> -
STALE1197d
LANDED [PATCH net-next v5 15/16] sock: Remove ->sendpage*() in favour of sendmsg(MSG_SPLICE_PAGES)
2023-06-23 · David Howells <dhowells@redhat.com> -
STALE1201d
[PATCH net-next v4 14/15] sock: Remove ->sendpage*() in favour of sendmsg(MSG_SPLICE_PAGES)
2023-06-23 · David Howells <dhowells@redhat.com> -
STALE1187d
[PATCH net-next v3 17/18] sock: Remove ->sendpage*() in favour of sendmsg(MSG_SPLICE_PAGES)
2023-06-20 · David Howells <dhowells@redhat.com> -
STALE1204d
[PATCH net-next v2 16/17] sock: Remove ->sendpage*() in favour of sendmsg(MSG_SPLICE_PAGES)
2023-06-17 · David Howells <dhowells@redhat.com> -
STALE1207d
[PATCH net-next 16/17] sock: Remove ->sendpage*() in favour of sendmsg(MSG_SPLICE_PAGES)
2023-06-16 · David Howells <dhowells@redhat.com> -
STALE1552d
REVIEWED: 4 (4M) [PATCH v2 11/19] mm/migrate: Add filemap_migrate_folio()
2022-06-08 · "Matthew Wilcox (Oracle)" <willy@infradead.org> -
STALE1552d
REVIEWED: 4 (4M) [PATCH v2 03/19] fs: Add aops->migrate_folio
2022-06-08 · "Matthew Wilcox (Oracle)" <willy@infradead.org> -
STALE1581d
[PATCH 09/20] mm/migrate: Add filemap_migrate_folio()
2022-06-06 · "Matthew Wilcox (Oracle)" <willy@infradead.org> -
STALE1581d
[PATCH 01/20] fs: Add aops->migrate_folio
2022-06-06 · "Matthew Wilcox (Oracle)" <willy@infradead.org> -
STALE2225d
[PATCH 1/9] Documentation/filesystems/locking.rst: remove an incorrect sentence
2020-09-01 · Christoph Hellwig <hch@lst.de> -
STALE4112d
[RFCv2 1/5] mm/compaction: enable driver page migration
2015-06-26 · Gioh Kim <hidden> -
STALE4137d
[RFC 1/4] mm/compaction: enable driver page migration
2015-06-02 · Gioh Kim <hidden> -
DORMANTno replies
[PATCH] add generic callbacks into compaction
2015-03-31 · Gioh Kim <hidden> -
STALE5062d
REVIEWED: 1 (0M) [PATCH v12 3/7] mm: introduce a common interface for balloon pages mobility
2012-11-11 · Rafael Aquini <hidden> -
STALE5061d
[PATCH v11 3/7] mm: introduce a common interface for balloon pages mobility
2012-11-07 · Rafael Aquini <hidden> -
STALE5124d
[PATCH v10 1/5] mm: introduce a common interface for balloon pages mobility
2012-09-17 · Rafael Aquini <hidden> -
STALE5152d
[PATCH v9 1/5] mm: introduce a common interface for balloon pages mobility
2012-08-25 · Rafael Aquini <hidden> -
STALE5157d
[PATCH v8 1/5] mm: introduce a common interface for balloon pages mobility
2012-08-21 · Rafael Aquini <hidden>
Quiet for 30+ days
Patches with no review trailers and no replies. Either the author is heads-down elsewhere or these slipped through. Oldest first.
-
COLD54d
[RFC PATCH v2 3/4] blk-cgroup: store blkcg in bio instead of blkg
2026-08-11 · Yu Kuai <yukuai@kernel.org>