iommufd · Maintained
Maintainers
- M Jason Gunthorpe <jgg@nvidia.com>
- M Kevin Tian <kevin.tian@intel.com>
Paths
- F
Documentation/userspace-api/iommufd.rst - F
drivers/iommu/iommufd/ - F
include/linux/iommufd.h - F
include/uapi/linux/iommufd.h - F
tools/testing/selftests/iommu/
Last 30 days
Recent patches
Most-recent 30 patches in this subsystem on virtualization (capped at 30), ordered by date desc.
-
COOLING10d
[PATCH RFC POC 49/50] iommufd: stop putting descriptors back on failure
2026-09-15 · Christian Brauner <brauner@kernel.org> -
STALE214d
LANDED: 11 (11M) [PATCH v7 8/8] iommufd: Add dma_buf_pin()
2026-01-31 · Leon Romanovsky <leon@kernel.org> -
STALE214d
REVIEWED: 3 (3M) [PATCH v7 2/8] dma-buf: Rename dma_buf_move_notify() to dma_buf_invalidate_mappings()
2026-01-31 · Leon Romanovsky <leon@kernel.org> -
STALE214d
REVIEWED: 3 (3M) [PATCH v7 1/8] dma-buf: Rename .move_notify() callback to a clearer identifier
2026-01-31 · Leon Romanovsky <leon@kernel.org> -
STALE239d
REVIEWED: 11 (11M) [PATCH v6 8/8] iommufd: Add dma_buf_pin()
2026-01-30 · Leon Romanovsky <leon@kernel.org> -
STALE239d
REVIEWED: 3 (3M) [PATCH v6 1/8] dma-buf: Rename .move_notify() callback to a clearer identifier
2026-01-30 · Leon Romanovsky <leon@kernel.org> -
STALE239d
REVIEWED: 3 (3M) [PATCH v6 2/8] dma-buf: Rename dma_buf_move_notify() to dma_buf_invalidate_mappings()
2026-01-30 · Leon Romanovsky <leon@kernel.org> -
STALE236d
REVIEWED: 3 (3M) [PATCH v5 8/8] iommufd: Add dma_buf_pin()
2026-01-24 · Leon Romanovsky <leon@kernel.org> -
STALE236d
LANDED: 3 (3M) [PATCH v5 1/8] dma-buf: Rename .move_notify() callback to a clearer identifier
2026-01-24 · Leon Romanovsky <leon@kernel.org> -
STALE236d
LANDED [PATCH v5 2/8] dma-buf: Rename dma_buf_move_notify() to dma_buf_invalidate_mappings()
2026-01-24 · Leon Romanovsky <leon@kernel.org> -
STALE247d
REVIEWED: 3 (3M) [PATCH v4 6/8] iommufd: Pin dma-buf importer for revoke semantics
2026-01-21 · Leon Romanovsky <leon@kernel.org> -
STALE247d
[PATCH v4 2/8] dma-buf: Rename dma_buf_move_notify() to dma_buf_invalidate_mappings()
2026-01-21 · Leon Romanovsky <leon@kernel.org> -
STALE247d
REVIEWED: 3 (3M) [PATCH v4 1/8] dma-buf: Rename .move_notify() callback to a clearer identifier
2026-01-21 · Leon Romanovsky <leon@kernel.org> -
STALE246d
[PATCH v3 5/7] iommufd: Pin dma-buf importer for revoke semantics
2026-01-20 · Leon Romanovsky <leon@kernel.org> -
STALE246d
REVIEWED: 3 (3M) [PATCH v3 1/7] dma-buf: Rename .move_notify() callback to a clearer identifier
2026-01-20 · Leon Romanovsky <leon@kernel.org> -
STALE249d
[PATCH v2 3/4] iommufd: Require DMABUF revoke semantics
2026-01-18 · Leon Romanovsky <leon@kernel.org> -
STALE249d
[PATCH v2 1/4] dma-buf: Rename .move_notify() callback to a clearer identifier
2026-01-18 · Leon Romanovsky <leon@kernel.org> -
STALE281d
REVIEWED: 8 (8M) [PATCH v2 6/6] iommu: Pass in old domain to attach_dev callback functions
2025-10-23 · Nicolin Chen <hidden> -
STALE323d
[PATCH v1 18/20] iommufd/selftest: Implement mock_domain_nop_test
2025-10-13 · Nicolin Chen <hidden> -
STALE341d
REVIEWED: 8 (8M) [PATCH v1 6/6] iommu: Pass in old domain to attach_dev callback functions
2025-10-12 · Nicolin Chen <hidden> -
STALE366d
[PATCH v4 4/7] iommu: Pass in old domain to attach_dev callback functions
2025-08-31 · Nicolin Chen <hidden> -
STALE456d
LANDED: 3 (3M) [PATCH v2 3/7] iommu: Remove ops.pgsize_bitmap from drivers that don't use it
2025-06-09 · Jason Gunthorpe <jgg@nvidia.com> -
STALE484d
[PATCH 3/7] iommu: Remove ops.pgsize_bitmap from drivers that don't use it
2025-04-29 · Jason Gunthorpe <jgg@nvidia.com> -
STALE698d
Re: [PATCH v8 07/10] iommufd: Fault-capable hwpt attach/detach/replace
2024-10-28 · Zhangfei Gao <zhangfei.gao@linaro.org> -
STALE698d
LANDED: 2 (2M) [PATCH v8 10/10] iommufd/selftest: Add coverage for IOPF test
2024-07-02 · Lu Baolu <baolu.lu@linux.intel.com> -
STALE698d
LANDED: 2 (2M) [PATCH v8 09/10] iommufd/selftest: Add IOPF support for mock device
2024-07-02 · Lu Baolu <baolu.lu@linux.intel.com> -
STALE698d
LANDED: 2 (2M) [PATCH v8 08/10] iommufd: Associate fault object with iommufd_hw_pgtable
2024-07-02 · Lu Baolu <baolu.lu@linux.intel.com> -
STALE698d
LANDED: 2 (2M) [PATCH v8 07/10] iommufd: Fault-capable hwpt attach/detach/replace
2024-07-02 · Lu Baolu <baolu.lu@linux.intel.com> -
STALE698d
LANDED: 8 (8M) [PATCH v8 06/10] iommufd: Add iommufd fault object
2024-07-02 · Lu Baolu <baolu.lu@linux.intel.com> -
STALE698d
LANDED: 2 (2M) [PATCH v8 05/10] iommufd: Add fault and response message definitions
2024-07-02 · Lu Baolu <baolu.lu@linux.intel.com>