dma buffer sharing framework · Maintained
Maintainers
- M Sumit Semwal <sumit.semwal@linaro.org>
- M Christian König <christian.koenig@amd.com>
Paths
- F
Documentation/driver-api/dma-buf.rst - F
Documentation/userspace-api/dma-buf-alloc-exchange.rst - F
drivers/dma-buf/ - F
include/linux/*fence.h - F
include/linux/dma-buf.h - F
include/linux/dma-buf/ - F
include/linux/dma-resv.h - F
rust/helpers/dma-resv.c
Last 30 days
Recent patches
Most-recent 30 patches in this subsystem on virtualization (capped at 30), ordered by date desc.
-
COOLING11d
[PATCH RFC POC 26/50] dma-buf: stop unwinding sync file descriptors by hand
2026-09-15 · Christian Brauner <brauner@kernel.org> -
COLD20d
[PATCH 1/3] drm: fix typos in comments
2026-09-04 · Hemanth Selam <hidden> -
STALE215d
LANDED [PATCH v7 5/8] dma-buf: Make .invalidate_mapping() truly optional
2026-01-31 · Leon Romanovsky <leon@kernel.org> -
STALE215d
LANDED [PATCH v7 6/8] dma-buf: Add dma_buf_attach_revocable()
2026-01-31 · Leon Romanovsky <leon@kernel.org> -
STALE215d
REVIEWED: 3 (3M) [PATCH v7 2/8] dma-buf: Rename dma_buf_move_notify() to dma_buf_invalidate_mappings()
2026-01-31 · Leon Romanovsky <leon@kernel.org> -
STALE215d
REVIEWED: 3 (3M) [PATCH v7 3/8] dma-buf: Always build with DMABUF_MOVE_NOTIFY
2026-01-31 · Leon Romanovsky <leon@kernel.org> -
STALE215d
REVIEWED: 3 (3M) [PATCH v7 1/8] dma-buf: Rename .move_notify() callback to a clearer identifier
2026-01-31 · Leon Romanovsky <leon@kernel.org> -
DORMANTno replies
[PATCH v6 5/8] dma-buf: Make .invalidate_mapping() truly optional
2026-01-30 · Leon Romanovsky <leon@kernel.org> -
STALE239d
[PATCH v6 6/8] dma-buf: Add dma_buf_attach_revocable()
2026-01-30 · Leon Romanovsky <leon@kernel.org> -
STALE239d
REVIEWED: 3 (3M) [PATCH v6 1/8] dma-buf: Rename .move_notify() callback to a clearer identifier
2026-01-30 · Leon Romanovsky <leon@kernel.org> -
STALE239d
REVIEWED: 3 (3M) [PATCH v6 3/8] dma-buf: Always build with DMABUF_MOVE_NOTIFY
2026-01-30 · Leon Romanovsky <leon@kernel.org> -
STALE239d
REVIEWED: 3 (3M) [PATCH v6 2/8] dma-buf: Rename dma_buf_move_notify() to dma_buf_invalidate_mappings()
2026-01-30 · Leon Romanovsky <leon@kernel.org> -
STALE236d
LANDED [PATCH v5 3/8] dma-buf: Always build with DMABUF_MOVE_NOTIFY
2026-01-24 · Leon Romanovsky <leon@kernel.org> -
STALE236d
[PATCH v5 6/8] dma-buf: Add dma_buf_attach_revocable()
2026-01-24 · Leon Romanovsky <leon@kernel.org> -
STALE236d
[PATCH v5 5/8] dma-buf: Make .invalidate_mapping() truly optional
2026-01-24 · Leon Romanovsky <leon@kernel.org> -
STALE236d
LANDED: 3 (3M) [PATCH v5 1/8] dma-buf: Rename .move_notify() callback to a clearer identifier
2026-01-24 · Leon Romanovsky <leon@kernel.org> -
STALE236d
LANDED [PATCH v5 2/8] dma-buf: Rename dma_buf_move_notify() to dma_buf_invalidate_mappings()
2026-01-24 · Leon Romanovsky <leon@kernel.org> -
STALE248d
Re: [PATCH v4 8/8] vfio: Validate dma-buf revocation semantics
2026-01-21 · Pranjal Shrivastava <praan@google.com> -
STALE248d
[PATCH v4 5/8] dma-buf: Add check function for revoke semantics
2026-01-21 · Leon Romanovsky <leon@kernel.org> -
STALE248d
[PATCH v4 3/8] dma-buf: Always build with DMABUF_MOVE_NOTIFY
2026-01-21 · Leon Romanovsky <leon@kernel.org> -
STALE248d
[PATCH v4 4/8] dma-buf: Make .invalidate_mapping() truly optional
2026-01-21 · Leon Romanovsky <leon@kernel.org> -
STALE248d
[PATCH v4 2/8] dma-buf: Rename dma_buf_move_notify() to dma_buf_invalidate_mappings()
2026-01-21 · Leon Romanovsky <leon@kernel.org> -
STALE248d
REVIEWED: 3 (3M) [PATCH v4 1/8] dma-buf: Rename .move_notify() callback to a clearer identifier
2026-01-21 · Leon Romanovsky <leon@kernel.org> -
STALE246d
REVIEWED: 3 (3M) [PATCH v3 1/7] dma-buf: Rename .move_notify() callback to a clearer identifier
2026-01-20 · Leon Romanovsky <leon@kernel.org> -
STALE246d
[PATCH v3 4/7] dma-buf: Add check function for revoke semantics
2026-01-20 · Leon Romanovsky <leon@kernel.org> -
STALE246d
[PATCH v3 3/7] dma-buf: Document RDMA non-ODP invalidate_mapping() special case
2026-01-20 · Leon Romanovsky <leon@kernel.org> -
STALE246d
[PATCH v3 2/7] dma-buf: Always build with DMABUF_MOVE_NOTIFY
2026-01-20 · Leon Romanovsky <leon@kernel.org> -
STALE249d
Re: [PATCH v2 2/4] dma-buf: Document revoke semantics
2026-01-20 · Leon Romanovsky <leon@kernel.org> -
STALE249d
Re: [PATCH v2 1/4] dma-buf: Rename .move_notify() callback to a clearer identifier
2026-01-19 · Leon Romanovsky <leon@kernel.org> -
STALE249d
[PATCH v2 2/4] dma-buf: Document revoke semantics
2026-01-18 · Leon Romanovsky <leon@kernel.org>