Re: Additional virtio-mmio spec changes

From: Peter Maydell <hidden>
Date: 2011-11-02 13:31:05

Rusty wrote:
Pawel Moll [off-list ref] wrote:
quoted
Peter also mentioned that he didn't like the "Num" in
"QueueNum" register name and would rather see it called "QueueSize". I
have no strong opinions either way and can provide patches to both the
spec and the driver (and header) to change it. Any thoughts?
Num isn't great, but Size might be misleading.  I'd leave it...
I'd note that calling it QueueNum  is inconsistent with the main
virtio spec, which calls the equivalent virtio header field
"Queue Size". Also if the docs say

"QueueNum
 Virtual queue size.
 Queue size is a number of elements in the queue [...]"

this rather suggests to me that we've picked the wrong name for
the register...

-- PMM
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help