Reviews by andriy.shevchenko@linux.intel.com
· platform-driver-x86
All review-attestation trailers
(Reviewed-by / Acked-by /
Tested-by / Reported-by /
Suggested-by / Co-developed-by /
Reported-and-tested-by)
by this address on the platform-driver-x86 archive.
100 attestations · capped at 100 most-recent. (8 Acked-by, 85 Reviewed-by, 7 Suggested-by)
-
COLD32d
REVIEWED: 7 (7M) Re: [PATCH v1] sonypi: Stop setting acpi_device_name/class()
2026-07-08 · Reviewed-by -
COLD32d
REVIEWED: 7 (7M) Re: [PATCH v1] sonypi: Stop setting acpi_device_name/class()
2026-07-08 · Reviewed-by -
COLD32d
REVIEWED: 7 (7M) Re: [PATCH v2] platform/surface: surfacepro3_button: Stop setting acpi_device_name()
2026-07-08 · Reviewed-by -
COLD32d
REVIEWED: 7 (7M) Re: [PATCH v1] x86/platform/olpc: xo15: Stop setting acpi_device_name/class()
2026-07-08 · Reviewed-by -
COLD28d
REVIEWED: 7 (7M) [PATCH v3 20/20] driver core: platform: count references to all kinds of firmware nodes
2026-07-06 · Reviewed-by -
COLD28d
REVIEWED: 15 (15M) [PATCH v3 19/20] reset: rzg2l: use platform_device_set_of_node_from_dev()
2026-07-06 · Reviewed-by -
COLD28d
REVIEWED: 7 (7M) [PATCH v3 18/20] usb: musb: use platform_device_set_of_node_from_dev()
2026-07-06 · Reviewed-by -
COLD28d
REVIEWED: 10 (10M) [PATCH v3 17/20] usb: chipidea: use platform_device_set_of_node_from_dev()
2026-07-06 · Reviewed-by -
COLD28d
REVIEWED: 14 (14M) [PATCH v3 16/20] platform/surface: gpe: use platform_device_set_fwnode()
2026-07-06 · Reviewed-by -
COLD28d
REVIEWED: 7 (7M) [PATCH v3 15/20] drm/xe/i2c: use platform_device_set_fwnode()
2026-07-06 · Reviewed-by -
COLD28d
REVIEWED: 19 (19M) [PATCH v3 14/20] net: mv643xx: use platform_device_set_of_node()
2026-07-06 · Reviewed-by -
COLD28d
REVIEWED: 11 (11M) [PATCH v3 13/20] slimbus: qcom-ngd-ctrl: use platform_device_set_of_node()
2026-07-06 · Reviewed-by -
COLD28d
REVIEWED: 13 (13M) [PATCH v3 09/20] iommu/fsl: use platform_device_set_of_node()
2026-07-06 · Reviewed-by -
COLD28d
REVIEWED: 11 (11M) [PATCH v3 12/20] mfd: tps6586: use platform_device_set_of_node()
2026-07-06 · Reviewed-by -
COLD28d
REVIEWED: 7 (7M) [PATCH v3 10/20] net: bcmgenet: use platform_device_set_of_node()
2026-07-06 · Reviewed-by -
COLD28d
REVIEWED: 19 (19M) [PATCH v3 11/20] pmdomain: imx: use platform_device_set_of_node()
2026-07-06 · Reviewed-by -
COLD28d
REVIEWED: 10 (10M) [PATCH v3 08/20] i2c: pxa-pci: use platform_device_set_of_node()
2026-07-06 · Reviewed-by -
COLD28d
REVIEWED: 14 (14M) [PATCH v3 06/20] of: platform: use platform_device_set_of_node()
2026-07-06 · Reviewed-by -
COLD28d
REVIEWED: 7 (7M) [PATCH v3 07/20] powerpc/powermac: use platform_device_set_of_node()
2026-07-06 · Reviewed-by -
COLD28d
REVIEWED: 7 (7M) [PATCH v3 04/20] driver core: platform: provide platform_device_set_of_node_from_dev()
2026-07-06 · Reviewed-by -
COLD28d
REVIEWED: 8 (7M) [PATCH v3 02/20] driver core: platform: provide platform_device_set_of_node()
2026-07-06 · Reviewed-by -
COLD28d
REVIEWED: 7 (7M) [PATCH v3 03/20] driver core: platform: provide platform_device_set_fwnode()
2026-07-06 · Reviewed-by -
COLD28d
REVIEWED: 7 (7M) [PATCH v3 01/20] powerpc/powermac: fix OF node refcount
2026-07-06 · Reviewed-by -
COLD35d
REVIEWED: 7 (7M) Re: [PATCH v1] platform/x86: topstar-laptop: Stop setting acpi_device_name/class()
2026-07-03 · Reviewed-by -
COLD35d
REVIEWED: 7 (7M) Re: [PATCH v1 00/10] platform/x86: Stop using acpi_device_name/class()
2026-07-03 · Reviewed-by -
COLD40d
REVIEWED: 7 (7M) Re: [PATCH v2 00/19] driver core: count references of the platform device's fwnode, not OF node
2026-06-29 · Reviewed-by -
COLD40d
REVIEWED: 7 (7M) Re: [PATCH v2 19/19] driver core: platform: count references to all kinds of firmware nodes
2026-06-29 · Reviewed-by -
STALE83d
REVIEWED: 7 (7M) Re: [PATCH v2] platform/x86: xo15-ebook: Use devres-based resource management
2026-05-17 · Reviewed-by -
STALE83d
REVIEWED: 7 (7M) Re: [PATCH v2 0/5] platform/x86: Check ACPI_COMPANION() or ACPI_HANDLE() against NULL
2026-05-12 · Reviewed-by -
STALE83d
REVIEWED: 7 (7M) Re: [PATCH v1] platform/surface: surfacepro3_button: Check ACPI_COMPANION()
2026-05-12 · Reviewed-by -
STALE83d
REVIEWED: 7 (7M) [PATCH v2 01/16] platform/x86: acer-wireless: Check ACPI_COMPANION() against NULL
2026-05-12 · Reviewed-by -
STALE83d
REVIEWED: 7 (7M) [PATCH v2 02/16] platform/x86: asus-laptop: Check ACPI_COMPANION() against NULL
2026-05-12 · Reviewed-by -
STALE83d
REVIEWED: 7 (7M) [PATCH v2 03/16] platform/x86: dell/dell-rbtn: Check ACPI_COMPANION() against NULL
2026-05-12 · Reviewed-by -
STALE83d
REVIEWED: 7 (7M) [PATCH v2 04/16] platform/x86: eeepc-laptop: Check ACPI_COMPANION() against NULL
2026-05-12 · Reviewed-by -
STALE83d
REVIEWED: 8 (8M) [PATCH v2 05/16] platform/x86: fujitsu: Check ACPI_COMPANION() against NULL
2026-05-12 · Reviewed-by -
STALE83d
REVIEWED: 7 (7M) [PATCH v2 06/16] platform/x86: fujitsu-tablet: Check ACPI_COMPANION() against NULL
2026-05-12 · Reviewed-by -
STALE83d
REVIEWED: 7 (7M) [PATCH v2 07/16] platform/x86: intel/rst: Check ACPI_COMPANION() against NULL
2026-05-12 · Reviewed-by -
STALE83d
REVIEWED: 7 (7M) [PATCH v2 08/16] platform/x86: intel/smartconnect: Check ACPI_HANDLE() against NULL
2026-05-12 · Reviewed-by -
STALE83d
REVIEWED: 7 (7M) [PATCH v2 09/16] platform/x86: lg-laptop: Check ACPI_COMPANION() against NULL
2026-05-12 · Reviewed-by -
STALE83d
REVIEWED: 7 (7M) [PATCH v2 10/16] platform/x86: panasonic-laptop: Check ACPI_COMPANION() against NULL
2026-05-12 · Reviewed-by -
STALE83d
REVIEWED: 7 (7M) [PATCH v2 11/16] platform/x86: sony-laptop: Check ACPI_COMPANION() against NULL
2026-05-12 · Reviewed-by -
STALE83d
REVIEWED: 7 (7M) [PATCH v2 12/16] platform/x86: system76: Check ACPI_COMPANION() against NULL
2026-05-12 · Reviewed-by -
STALE83d
REVIEWED: 7 (7M) [PATCH v2 13/16] platform/x86: toshiba_acpi: Check ACPI_COMPANION() against NULL
2026-05-12 · Reviewed-by -
STALE83d
REVIEWED: 7 (7M) [PATCH v2 14/16] platform/x86: toshiba_bluetooth: Check ACPI_COMPANION() against NULL
2026-05-12 · Reviewed-by -
STALE83d
REVIEWED: 7 (7M) [PATCH v2 15/16] platform/x86: toshiba_haps: Check ACPI_COMPANION() against NULL
2026-05-12 · Reviewed-by -
STALE83d
REVIEWED: 7 (7M) [PATCH v2 16/16] platform/x86: wireless-hotkey: Check ACPI_COMPANION() against NULL
2026-05-12 · Reviewed-by -
STALE90d
REVIEWED: 7 (7M) Re: [PATCH v1] platform/x86: Check ACPI_COMPANION() against NULL during probe
2026-05-12 · Reviewed-by -
STALE94d
REVIEWED: 7 (7M) Re: [PATCH v5 2/2] platform/x86: x86-android-tablets: enable fwnode matching of GPIO chips
2026-05-04 · Reviewed-by -
STALE94d
REVIEWED: 7 (7M) Re: [PATCH v5 1/2] ACPI: provide acpi_bus_find_device_by_name()
2026-05-04 · Reviewed-by -
STALE104d
REVIEWED: 14 (14M) [PATCH v5] platform/x86: meraki-mx100: use real software node references
2026-04-27 · Acked-by -
STALE123d
REVIEWED: 7 (7M) Re: [PATCH v4 2/2] gpio: swnode: defer probe on references to unregistered software nodes
2026-04-07 · Reviewed-by -
STALE122d
REVIEWED: 7 (7M) Re: [PATCH v8 4/4] platform/x86: int3472: Add support for GPIO type 0x02 (IR flood LED)
2026-04-02 · Reviewed-by -
STALE122d
REVIEWED: 8 (7M) [PATCH v8 2/4] platform/x86: int3472: Rename pled to led in LED registration code
2026-04-01 · Reviewed-by -
STALE122d
REVIEWED: 8 (7M) [PATCH v8 1/4] platform/x86: int3472: Use local variable for LED struct access
2026-04-01 · Reviewed-by -
STALE122d
REVIEWED: 8 (7M) [PATCH v8 3/4] platform/x86: int3472: Parameterize LED con_id in registration
2026-04-01 · Reviewed-by -
STALE131d
REVIEWED: 7 (7M) Re: [PATCH v7 4/4] platform/x86: int3472: Add support for GPIO type 0x02 (IR flood LED)
2026-03-31 · Reviewed-by -
STALE131d
REVIEWED: 7 (7M) Re: [PATCH v7 3/4] platform/x86: int3472: Parameterize LED con_id in registration
2026-03-31 · Reviewed-by -
STALE131d
REVIEWED: 7 (7M) [PATCH v7 1/4] platform/x86: int3472: Use local variable for LED struct access
2026-03-31 · Reviewed-by -
STALE131d
REVIEWED: 7 (7M) [PATCH v7 2/4] platform/x86: int3472: Rename pled to led in LED registration code
2026-03-31 · Reviewed-by -
STALE131d
REVIEWED: 7 (7M) Re: [PATCH v6 4/4] platform/x86: int3472: Add support for GPIO type 0x02 (IR flood LED)
2026-03-31 · Reviewed-by -
STALE131d
REVIEWED: 7 (7M) Re: [PATCH v6 3/4] platform/x86: int3472: Parameterize LED con_id in registration
2026-03-31 · Reviewed-by -
STALE131d
REVIEWED: 7 (7M) Re: [PATCH v6 2/4] platform/x86: int3472: Rename pled to led in LED registration code
2026-03-31 · Reviewed-by -
STALE131d
REVIEWED: 7 (7M) Re: [PATCH v6 1/4] platform/x86: int3472: Use local variable for LED struct access
2026-03-31 · Reviewed-by -
STALE131d
REVIEWED: 7 (7M) Re: [PATCH v4 1/4] platform/x86: int3472: Rename pled to led in LED registration code
2026-03-27 · Reviewed-by -
DORMANTno replies
REVIEWED: 7 (7M) [PATCH v4] platform/x86: meraki-mx100: use real software node references
2026-03-25 · Acked-by -
STALE140d
REVIEWED: 7 (7M) [PATCH v3] platform/x86: meraki-mx100: use real software node references
2026-03-16 · Acked-by -
STALE154d
REVIEWED: 7 (7M) [PATCH v2 2/2] platform/x86: meraki-mx100: use real software node references
2026-02-18 · Acked-by -
STALE154d
REVIEWED: 7 (7M) [PATCH v2 1/2] mfd: lpc_ich: expose the GPIO controller cell's software node
2026-02-18 · Acked-by -
STALE174d
REVIEWED: 7 (7M) Re: [PATCH 0/2] platform/x86: meraki-mx100: create and use real software node links
2026-02-13 · Acked-by -
STALE172d
REVIEWED: 7 (7M) [PATCH v2] gpio: swnode: restore the swnode-name-against-chip-label matching
2026-02-11 · Acked-by -
STALE181d
REVIEWED: 7 (7M) Re: [PATCH] gpio: swnode: restore the swnode-name-against-chip-label matching
2026-02-10 · Acked-by -
STALE220d
REVIEWED: 7 (7M) Re: [PATCH v1] ACPI: scan: Use resource_type() for resource type checking
2025-12-30 · Reviewed-by -
STALE250d
REVIEWED: 7 (7M) Re: [PATCH v2] platform/x86: asus-wmi: use brightness_set_blocking() for kbd led
2025-11-29 · Reviewed-by -
STALE255d
REVIEWED: 7 (7M) Re: [PATCH v5] platform/x86: serial-multi-instantiate: Add IRQ_RESOURCE_OPT for IRQ missing projects
2025-11-26 · Reviewed-by -
STALE264d
LANDED: 8 (7M) [PATCH v3 2/2] gpio: elkhartlake: Convert to auxiliary driver
2025-11-12 · Reviewed-by -
STALE273d
REVIEWED: 8 (7M) [PATCH v2 2/2] gpio: elkhartlake: Convert to auxiliary driver
2025-11-10 · Reviewed-by -
STALE277d
[PATCH v2] mod_devicetable: Bump auxiliary_device_id name size
2025-11-06 · Suggested-by -
STALE283d
REVIEWED: 7 (7M) Re: [PATCH v1 2/2] gpio: elkhartlake: Convert to auxiliary driver
2025-10-29 · Reviewed-by -
STALE295d
REVIEWED: 7 (7M) [PATCH v2 03/27 5.10.y] minmax: sanity check constant bounds when clamping
2025-10-17 · Reviewed-by -
STALE322d
REVIEWED: 7 (7M) [PATCH 02/27 5.10.y] minmax: sanity check constant bounds when clamping
2025-09-19 · Reviewed-by -
DORMANTno replies
REVIEWED: 7 (7M) Re: [PATCH v4 1/1] platform/x86: int3472: add hpd pin support
2025-07-02 · Reviewed-by -
STALE425d
REVIEWED: 7 (7M) Re: [PATCH v4 2/2] platform/x86: Move Lenovo files into lenovo subdir
2025-06-10 · Reviewed-by -
STALE425d
REVIEWED: 7 (7M) Re: [PATCH v4 1/2] platform/x86: thinklmi: improved DMI handling
2025-06-10 · Reviewed-by -
STALE461d
REVIEWED: 14 (14M) [PATCH AUTOSEL 6.12 05/18] platform/x86/intel: hid: Add Pantherlake support
2025-05-06 · Suggested-by -
STALE461d
REVIEWED: 14 (14M) [PATCH AUTOSEL 6.12 05/18] platform/x86/intel: hid: Add Pantherlake support
2025-05-06 · Reviewed-by -
STALE461d
REVIEWED: 14 (14M) [PATCH AUTOSEL 6.14 05/20] platform/x86/intel: hid: Add Pantherlake support
2025-05-06 · Suggested-by -
STALE461d
REVIEWED: 14 (14M) [PATCH AUTOSEL 6.14 05/20] platform/x86/intel: hid: Add Pantherlake support
2025-05-06 · Reviewed-by -
STALE460d
REVIEWED: 7 (7M) [PATCH 5/7] soundwire: sysfs: Use ATTRIBUTE_GROUP_VISIBLE()
2025-04-23 · Reviewed-by -
STALE460d
REVIEWED: 7 (7M) [PATCH 2/7] sysfs: Introduce macros to simplify creation of visible attribute groups
2025-04-23 · Reviewed-by -
STALE460d
[PATCH 3/7] docs: sysfs.rst: document additional attribute group macros
2025-04-23 · Suggested-by -
STALE474d
REVIEWED: 7 (7M) Re: [PATCH] platform/x86/intel: hid: Add Pantherlake support
2025-04-22 · Reviewed-by -
STALE474d
LANDED [PATCH] platform/x86/intel: hid: Add Pantherlake support
2025-04-21 · Suggested-by -
STALE518d
LANDED: 8 (7M) [PATCH v2 1/1] cleanup: Fix sparse complaining about passing iomem ptr to no_free_ptr()
2025-03-10 · Reviewed-by -
STALE532d
REVIEWED: 7 (7M) Re: [PATCH 4/4] platform/x86: intel: Use *-y instead of *-objs in Makefile
2025-02-19 · Reviewed-by -
STALE538d
REVIEWED: 15 (14M) [PATCH AUTOSEL 6.12 18/31] platform/x86: int3472: Call "reset" GPIO "enable" for INT347E
2025-02-18 · Reviewed-by -
STALE538d
REVIEWED: 15 (14M) [PATCH AUTOSEL 6.12 17/31] platform/x86: int3472: Use correct type for "polarity", call it gpio_flags
2025-02-18 · Reviewed-by -
STALE538d
REVIEWED: 15 (14M) [PATCH AUTOSEL 6.13 18/31] platform/x86: int3472: Call "reset" GPIO "enable" for INT347E
2025-02-18 · Reviewed-by -
STALE538d
REVIEWED: 15 (14M) [PATCH AUTOSEL 6.13 17/31] platform/x86: int3472: Use correct type for "polarity", call it gpio_flags
2025-02-18 · Reviewed-by -
STALE532d
LANDED [PATCH 4/4] platform/x86: intel: Use *-y instead of *-objs in Makefile
2025-02-18 · Suggested-by -
STALE532d
LANDED [PATCH 3/4] platform/x86: hp: Use *-y instead of *-objs in Makefile
2025-02-18 · Suggested-by