fix the append with a leading blank, otherwise this messes up
DEPENDS when globally inherited classes add dependecies of their own
Signed-off-by: Konrad Weihmann <redacted>
---
meta/recipes-core/glib-2.0/glib.inc | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/meta/recipes-core/glib-2.0/glib.inc b/meta/recipes-core/glib-2.0/glib.inc
index a34776b083..3436645f15 100644
--- a/meta/recipes-core/glib-2.0/glib.inc
+++ b/meta/recipes-core/glib-2.0/glib.inc
@@ -30,7 +30,7 @@ LEAD_SONAME = "libglib-2.0.*"
inherit meson gettext gtk-doc pkgconfig ptest-gnome upstream-version-is-even bash-completion gio-module-cache manpages
-DEPENDS:append:class-target = "${@' gtk-doc' if d.getVar('GTKDOC_ENABLED') == 'True' else ''}"
+DEPENDS:append:class-target = " ${@' gtk-doc' if d.getVar('GTKDOC_ENABLED') == 'True' else ''}"
GTKDOC_MESON_OPTION = "gtk_doc"
--
2.25.1
quoted hunk
-----Original Message-----
From: openembedded-core@lists.openembedded.org <openembedded-
core@lists.openembedded.org> On Behalf Of Konrad Weihmann
Sent: den 4 oktober 2021 15:29
To: openembedded-core@lists.openembedded.org
Cc: Konrad Weihmann <redacted>
Subject: [OE-core] [PATCH 2/3] glibc: fix append in DEPENDS
fix the append with a leading blank, otherwise this messes up
DEPENDS when globally inherited classes add dependecies of their own
Signed-off-by: Konrad Weihmann <redacted>
---
meta/recipes-core/glib-2.0/glib.inc | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/meta/recipes-core/glib-2.0/glib.inc b/meta/recipes-core/glib-
2.0/glib.inc
index a34776b083..3436645f15 100644
--- a/meta/recipes-core/glib-2.0/glib.inc
+++ b/meta/recipes-core/glib-2.0/glib.inc
@@ -30,7 +30,7 @@ LEAD_SONAME = "libglib-2.0.*"
inherit meson gettext gtk-doc pkgconfig ptest-gnome upstream-version-is-
even bash-completion gio-module-cache manpages
-DEPENDS:append:class-target = "${@' gtk-doc' if d.getVar('GTKDOC_ENABLED') == 'True' else ''}"
+DEPENDS:append:class-target = " ${@' gtk-doc' if d.getVar('GTKDOC_ENABLED') == 'True' else ''}"
This change is not needed as there already is a space inside
the if statement (in ' gtk-doc').
GTKDOC_MESON_OPTION = "gtk_doc"
--
2.25.1
//Peter
On 04.10.21 17:08, Peter Kjellerstedt wrote:
quoted
-----Original Message-----
From: openembedded-core@lists.openembedded.org <openembedded-
core@lists.openembedded.org> On Behalf Of Konrad Weihmann
Sent: den 4 oktober 2021 15:29
To: openembedded-core@lists.openembedded.org
Cc: Konrad Weihmann <redacted>
Subject: [OE-core] [PATCH 2/3] glibc: fix append in DEPENDS
fix the append with a leading blank, otherwise this messes up
DEPENDS when globally inherited classes add dependecies of their own
Signed-off-by: Konrad Weihmann <redacted>
---
meta/recipes-core/glib-2.0/glib.inc | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/meta/recipes-core/glib-2.0/glib.inc b/meta/recipes-core/glib-
2.0/glib.inc
index a34776b083..3436645f15 100644
--- a/meta/recipes-core/glib-2.0/glib.inc
+++ b/meta/recipes-core/glib-2.0/glib.inc
@@ -30,7 +30,7 @@ LEAD_SONAME = "libglib-2.0.*"
inherit meson gettext gtk-doc pkgconfig ptest-gnome upstream-version-is-
even bash-completion gio-module-cache manpages
-DEPENDS:append:class-target = "${@' gtk-doc' if d.getVar('GTKDOC_ENABLED') == 'True' else ''}"
+DEPENDS:append:class-target = " ${@' gtk-doc' if d.getVar('GTKDOC_ENABLED') == 'True' else ''}"
This change is not needed as there already is a space inside
the if statement (in ' gtk-doc').
Still this is very prone to errors, so I personally rather have a space too much than to few (esp. as the else clause doesn't add a space).
IHMO it should be for readability purpose rather " ${@'gtk-doc' if d.getVar('GTKDOC_ENABLED') == 'True' else ''}" than like it is now - but that's just cosmetics and I'm sure one could discuss about that a lot
quoted
GTKDOC_MESON_OPTION = "gtk_doc"
--
2.25.1
//Peter
Still this is very prone to errors, so I personally rather have a
space too much than to few (esp. as the else clause doesn't add a space).
The missing space in else clause is often intentional in cases like this,
so that the append has no impact on value when not enabled
with GTKDOC_ENABLED. Why should it add useless space when not enabled? Just
for the possibility of someone adding something to else clause without
leading space there?
On Mon, Oct 4, 2021 at 5:14 PM Konrad Weihmann [off-list ref]
wrote:
On 04.10.21 17:08, Peter Kjellerstedt wrote:
quoted
quoted
-----Original Message-----
From: openembedded-core@lists.openembedded.org <openembedded-
core@lists.openembedded.org> On Behalf Of Konrad Weihmann
Sent: den 4 oktober 2021 15:29
To: openembedded-core@lists.openembedded.org
Cc: Konrad Weihmann <redacted>
Subject: [OE-core] [PATCH 2/3] glibc: fix append in DEPENDS
fix the append with a leading blank, otherwise this messes up
DEPENDS when globally inherited classes add dependecies of their own
Signed-off-by: Konrad Weihmann <redacted>
---
meta/recipes-core/glib-2.0/glib.inc | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/meta/recipes-core/glib-2.0/glib.inc
b/meta/recipes-core/glib-
quoted
quoted
2.0/glib.inc
index a34776b083..3436645f15 100644
--- a/meta/recipes-core/glib-2.0/glib.inc
+++ b/meta/recipes-core/glib-2.0/glib.inc
@@ -30,7 +30,7 @@ LEAD_SONAME = "libglib-2.0.*"
inherit meson gettext gtk-doc pkgconfig ptest-gnome
upstream-version-is-
quoted
quoted
even bash-completion gio-module-cache manpages
-DEPENDS:append:class-target = "${@' gtk-doc' if
d.getVar('GTKDOC_ENABLED') == 'True' else ''}"quoted
quoted
+DEPENDS:append:class-target = " ${@' gtk-doc' if
d.getVar('GTKDOC_ENABLED') == 'True' else ''}"quoted
This change is not needed as there already is a space inside
the if statement (in ' gtk-doc').
Still this is very prone to errors, so I personally rather have a space
too much than to few (esp. as the else clause doesn't add a space).
IHMO it should be for readability purpose rather " ${@'gtk-doc' if
d.getVar('GTKDOC_ENABLED') == 'True' else ''}" than like it is now - but
that's just cosmetics and I'm sure one could discuss about that a lot
quoted
quoted
GTKDOC_MESON_OPTION = "gtk_doc"
--
2.25.1
//Peter
-=-=-=-=-=-=-=-=-=-=-=-
Links: You receive all messages sent to this group.
View/Reply Online (#156611):
https://lists.openembedded.org/g/openembedded-core/message/156611
Mute This Topic: https://lists.openembedded.org/mt/86066304/3617156
Group Owner: openembedded-core+owner@lists.openembedded.org
Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [
Martin.Jansa@gmail.com]
-=-=-=-=-=-=-=-=-=-=-=-
On 04.10.21 17:29, Martin Jansa wrote:
> Still this is very prone to errors, so I personally rather have a space too much than to few (esp. as the else clause doesn't add a space).
The missing space in else clause is often intentional in cases like this, so that the append has no impact on value when not enabled with GTKDOC_ENABLED. Why should it add useless space when not enabled? Just for the possibility of someone adding something to else clause without leading space there?
Partly yes, I found those conditionals rather hard to review, esp. for more complex scenarios, so I kind of would suggest to add the mandatory space for the append operation all the time and add no additional space in the stuff that is popping out of the conditional computation.
But I'm also fine with dropping the last 2 patches of the series.
Only the first patch solves a real world issue... the remaining two were just a result of a linter scan
On Mon, Oct 4, 2021 at 5:14 PM Konrad Weihmann <kweihmann@outlook.com <mailto:kweihmann@outlook.com>> wrote:
On 04.10.21 17:08, Peter Kjellerstedt wrote:
>> -----Original Message-----
>> From: openembedded-core@lists.openembedded.org
<mailto:openembedded-core@lists.openembedded.org> <openembedded-
>> core@lists.openembedded.org
<mailto:core@lists.openembedded.org>> On Behalf Of Konrad Weihmann
>> Sent: den 4 oktober 2021 15:29
>> To: openembedded-core@lists.openembedded.org
<mailto:openembedded-core@lists.openembedded.org>
>> Cc: Konrad Weihmann <kweihmann@outlook.com
<mailto:kweihmann@outlook.com>>
>> Subject: [OE-core] [PATCH 2/3] glibc: fix append in DEPENDS
>>
>> fix the append with a leading blank, otherwise this messes up
>> DEPENDS when globally inherited classes add dependecies of their own
>>
>> Signed-off-by: Konrad Weihmann <kweihmann@outlook.com
<mailto:kweihmann@outlook.com>>
>> ---
>> meta/recipes-core/glib-2.0/glib.inc | 2 +-
>> 1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/meta/recipes-core/glib-2.0/glib.inc
b/meta/recipes-core/glib-
>> 2.0/glib.inc
>> index a34776b083..3436645f15 100644
>> --- a/meta/recipes-core/glib-2.0/glib.inc
>> +++ b/meta/recipes-core/glib-2.0/glib.inc
>> @@ -30,7 +30,7 @@ LEAD_SONAME = "libglib-2.0.*"
>>
>> inherit meson gettext gtk-doc pkgconfig ptest-gnome
upstream-version-is-
>> even bash-completion gio-module-cache manpages
>>
>> -DEPENDS:append:class-target = "${@' gtk-doc' if
d.getVar('GTKDOC_ENABLED') == 'True' else ''}"
>> +DEPENDS:append:class-target = " ${@' gtk-doc' if
d.getVar('GTKDOC_ENABLED') == 'True' else ''}"
>
> This change is not needed as there already is a space inside
> the if statement (in ' gtk-doc').
Still this is very prone to errors, so I personally rather have a space
too much than to few (esp. as the else clause doesn't add a space).
IHMO it should be for readability purpose rather " ${@'gtk-doc' if
d.getVar('GTKDOC_ENABLED') == 'True' else ''}" than like it is now -
but
that's just cosmetics and I'm sure one could discuss about that a lot
>
>>
>> GTKDOC_MESON_OPTION = "gtk_doc"
>>
>> --
>> 2.25.1
>
> //Peter
>
-=-=-=-=-=-=-=-=-=-=-=-
Links: You receive all messages sent to this group.
View/Reply Online (#156611):
https://lists.openembedded.org/g/openembedded-core/message/156611
<https://lists.openembedded.org/g/openembedded-core/message/156611>
Mute This Topic: https://lists.openembedded.org/mt/86066304/3617156
<https://lists.openembedded.org/mt/86066304/3617156>
Group Owner: openembedded-core+owner@lists.openembedded.org
<mailto:openembedded-core%2Bowner@lists.openembedded.org>
Unsubscribe:
https://lists.openembedded.org/g/openembedded-core/unsub
<https://lists.openembedded.org/g/openembedded-core/unsub>
[Martin.Jansa@gmail.com <mailto:Martin.Jansa@gmail.com>]
-=-=-=-=-=-=-=-=-=-=-=-