documentation · Maintained
Maintainers
- M Jonathan Corbet <corbet@lwn.net>
- R Shuah Khan <skhan@linuxfoundation.org>
Paths
- F
Documentation/ - F
tools/lib/python/ - F
tools/docs/ - F
tools/net/ynl/pyynl/lib/doc_generator.py - X
Documentation/ABI/ - X
Documentation/admin-guide/media/ - X
Documentation/devicetree/ - X
Documentation/driver-api/media/ - X
Documentation/firmware-guide/acpi/ - X
Documentation/i2c/ - X
Documentation/netlink/ - X
Documentation/power/ - X
Documentation/spi/ - X
Documentation/userspace-api/media/
Last 30 days
Most active threads (last 7 days)
-
HOTtoday
[PATCH v5 00/21] netfs: Keep track of folios in a segmented bio_vec[] chain
2026-07-06 15:36 · 1 reply in 7d · David Howells <dhowells@redhat.com>
Recent patches
Most-recent 30 patches in this subsystem on netfs (capped at 30), ordered by date desc.
-
HOTtoday
[PATCH v5 18/21] netfs: Remove folio_queue and rolling_buffer
2026-07-06 · David Howells <dhowells@redhat.com> -
COLD20d
[PATCH v4 26/30] netfs: Remove folio_queue and rolling_buffer
2026-06-16 · David Howells <dhowells@redhat.com> -
COLD28d
[PATCH v3 19/22] netfs: Remove folio_queue and rolling_buffer
2026-06-08 · David Howells <dhowells@redhat.com> -
COLD32d
[PATCH v2 18/21] netfs: Remove folio_queue and rolling_buffer
2026-05-18 · David Howells <dhowells@redhat.com> -
COLD58d
[PATCH v2 2/4] docs: fix repeated word 'that' across documentation
2026-05-09 · Adrien Reynard <hidden> -
COLD58d
[PATCH 2/5] docs: fix repeated word 'that' across documentation
2026-05-08 · Adrien Reynard <hidden> -
STALE83d
[PATCH 23/26] netfs: Remove folio_queue and rolling_buffer
2026-03-26 · David Howells <dhowells@redhat.com> -
STALE109d
[PATCH v2 2/2] tree-wide: rename do_exit() to task_exit()
2026-03-10 · Christian Brauner <brauner@kernel.org> -
STALE104d
[RFC PATCH 15/17] netfs: Remove folio_queue and rolling_buffer
2026-03-04 · David Howells <dhowells@redhat.com> -
STALE119d
REVIEWED: 4 (4M) [PATCH v3 15/15] VFS: unexport lock_rename(), lock_rename_child(), unlock_rename()
2026-02-24 · NeilBrown <hidden> -
STALE119d
REVIEWED: 4 (4M) [PATCH v3 08/15] VFS: make lookup_one_qstr_excl() static.
2026-02-24 · NeilBrown <hidden> -
STALE132d
REVIEWED: 4 (4M) [PATCH v2 15/15] VFS: unexport lock_rename(), lock_rename_child(), unlock_rename()
2026-02-23 · NeilBrown <hidden> -
STALE132d
REVIEWED: 4 (4M) [PATCH v2 08/15] VFS: make lookup_one_qstr_excl() static.
2026-02-23 · NeilBrown <hidden> -
STALE133d
[PATCH 13/13] VFS: unexport lock_rename(), lock_rename_child(), unlock_rename()
2026-02-04 · NeilBrown <hidden> -
STALE133d
[PATCH 07/13] VFS: make lookup_one_qstr_excl() static.
2026-02-04 · NeilBrown <hidden> -
STALE175d
REVIEWED: 13 (12M) [PATCH v6 14/15] VFS: change vfs_mkdir() to unlock on failure.
2025-11-13 · NeilBrown <hidden> -
STALE235d
REVIEWED: 8 (8M) [PATCH v5 13/14] VFS: change vfs_mkdir() to unlock on failure.
2025-11-06 · NeilBrown <hidden> -
STALE242d
REVIEWED: 8 (8M) [PATCH v4 13/14] VFS: change vfs_mkdir() to unlock on failure.
2025-10-29 · NeilBrown <hidden> -
STALE275d
[PATCH] fs: doc: Fix typos
2025-10-01 · Bhanu Seshu Kumar Valluri <hidden> -
STALE283d
[PATCH v3 20/38] nfs_common: add new NOTIFY4_* flags proposed in RFC8881bis
2025-09-24 · Jeff Layton <jlayton@kernel.org> -
STALE283d
[PATCH v3 19/38] nfsd: add protocol support for CB_NOTIFY
2025-09-24 · Jeff Layton <jlayton@kernel.org> -
STALE130d
[PATCH 10/11] VFS: use d_alloc_parallel() in lookup_one_qstr_excl().
2025-08-12 · NeilBrown <neil@brown.name> -
STALE130d
[PATCH 08/11] VFS: allow d_splice_alias() and d_add() to work on hashed dentries.
2025-08-12 · NeilBrown <neil@brown.name> -
STALE130d
[PATCH 09/11] VFS: use global wait-queue table for d_alloc_parallel()
2025-08-12 · NeilBrown <neil@brown.name> -
STALE389d
LANDED [PATCH 2/5] VFS: Minor fixes for porting.rst
2025-06-08 · NeilBrown <neil@brown.name> -
STALE412d
LANDED [PATCH 09/11] folio_queue: remove unused field `marks3`
2025-05-19 · David Howells <dhowells@redhat.com> -
STALE412d
LANDED [PATCH 02/11] fs/netfs: remove unused flag NETFS_SREQ_SEEK_DATA_READ
2025-05-19 · David Howells <dhowells@redhat.com> -
STALE412d
REVIEWED: 1 (0M) [PATCH 01/11] netfs: Update main API document
2025-05-19 · David Howells <dhowells@redhat.com> -
DORMANTno replies
[PATCH] fs/netfs: remove unused flag NETFS_SREQ_SEEK_DATA_READ
2025-04-28 · Max Kellermann <hidden> -
STALE451d
LANDED: 1 (0M) [PATCH v2] netfs: Update main API document
2025-04-09 · David Howells <dhowells@redhat.com>
Needs attention (review trailers in, no pickup)
Patches with review trailers that haven't landed in mainline and haven't been Acked by a maintainer. Oldest first.
-
STALE119d
REVIEWED: 4 (4M) [PATCH v3 15/15] VFS: unexport lock_rename(), lock_rename_child(), unlock_rename()
2026-02-24 · NeilBrown <hidden> · 1 Reviewed-by
Quiet for 30+ days
Patches with no review trailers and no replies. Either the author is heads-down elsewhere or these slipped through. Oldest first.
-
STALE104d
[RFC PATCH 15/17] netfs: Remove folio_queue and rolling_buffer
2026-03-04 · David Howells <dhowells@redhat.com> -
STALE83d
[PATCH 23/26] netfs: Remove folio_queue and rolling_buffer
2026-03-26 · David Howells <dhowells@redhat.com> -
COLD32d
[PATCH v2 18/21] netfs: Remove folio_queue and rolling_buffer
2026-05-18 · David Howells <dhowells@redhat.com>