fpga manager framework · Maintained
Maintainers
- M Moritz Fischer <mdf@kernel.org>
- M Xu Yilun <yilun.xu@intel.com>
- R Tom Rix <trix@redhat.com>
Paths
- F
Documentation/devicetree/bindings/fpga/ - F
Documentation/driver-api/fpga/ - F
Documentation/fpga/ - F
drivers/fpga/ - F
include/linux/fpga/
Last 30 days
Recent patches
Most-recent 30 patches in this subsystem on netdev (capped at 30), ordered by date desc.
-
STALE142d
[PATCH 09/10] fpga: manager: switch to using class_find_device_by_fwnode()
2026-03-23 · Dmitry Torokhov <dmitry.torokhov@gmail.com> -
STALE142d
[PATCH 08/10] fpga: bridge: switch to using class_find_device_by_fwnode()
2026-03-23 · Dmitry Torokhov <dmitry.torokhov@gmail.com> -
STALE210d
[PATCH 09/12] fpga: m10bmc-sec: switch show_canceled_csk() to using scnprintf()
2026-02-19 · Yury Norov <hidden> -
STALE333d
[PATCH] dt-bindings: Remove extra blank lines
2025-10-23 · "Rob Herring (Arm)" <robh@kernel.org> -
STALE698d
LANDED: 14 (14M) [PATCH v8 3/6] fpga/dfl-pci.c: Replace deprecated PCI functions
2024-10-16 · Philipp Stanner <hidden> -
STALE715d
REVIEWED: 14 (14M) [PATCH v7 2/5] fpga/dfl-pci.c: Replace deprecated PCI functions
2024-10-14 · Philipp Stanner <hidden> -
STALE721d
REVIEWED: 14 (14M) [PATCH v6 2/5] fpga/dfl-pci.c: Replace deprecated PCI functions
2024-09-02 · Philipp Stanner <hidden> -
STALE760d
REVIEWED: 14 (14M) [PATCH v5 2/7] fpga/dfl-pci.c: Replace deprecated PCI functions
2024-08-29 · Philipp Stanner <hidden> -
STALE762d
REVIEWED: 14 (14M) [PATCH v4 2/7] fpga/dfl-pci.c: Replace deprecated PCI functions
2024-08-27 · Philipp Stanner <hidden> -
STALE763d
[PATCH v3 2/9] fpga/dfl-pci.c: Replace deprecated PCI functions
2024-08-22 · Philipp Stanner <hidden> -
STALE769d
[PATCH v2 2/9] fpga/dfl-pci.c: Replace deprecated PCI functions
2024-08-21 · Philipp Stanner <hidden> -
STALE770d
[PATCH 3/9] fpga/dfl-pci.c: Replace deprecated PCI functions
2024-08-19 · Philipp Stanner <hidden> -
STALE610d
[PATCH 33/34] drivers: remove incorrect of_match_ptr/ACPI_PTR annotations
2024-04-03 · Arnd Bergmann <arnd@kernel.org> -
STALE964d
LANDED [PATCH v2 2/4] eventfd: simplify eventfd_signal()
2023-11-22 · Christian Brauner <brauner@kernel.org> -
STALE1173d
[PATCH 1/2] eventfd: simplify eventfd_signal()
2023-07-13 · Christian Brauner <brauner@kernel.org> -
STALE1272d
[PATCH v2 09/10] fpga: lattice-sysconfig-spi: Add explicit include for of.h
2023-04-05 · Rob Herring <robh@kernel.org> -
STALE1895d
LANDED: 47 (47M) [PATCH v4 5/5] bus: Make remove callback return void
2021-07-13 · Uwe Kleine-König <hidden> -
STALE1904d
REVIEWED: 47 (47M) [PATCH v3 5/5] bus: Make remove callback return void
2021-07-13 · Uwe Kleine-König <hidden> -
STALE1902d
REVIEWED: 45 (45M) [PATCH v2 4/4] bus: Make remove callback return void
2021-07-06 · Uwe Kleine-König <hidden> -
STALE1909d
[PATCH] bus: Make remove callback return void
2021-07-06 · Uwe Kleine-König <hidden> -
STALE1966d
Re: [PATCH 00/53] Get rid of UTF-8 chars that can be mapped as ASCII
2021-05-10 · Mauro Carvalho Chehab <mchehab+huawei@kernel.org> -
STALE2002d
[PATCH v3 12/15] fpga: altera: use ARCH_INTEL_SOCFPGA also for 32-bit ARM SoCs
2021-03-11 · Krzysztof Kozlowski <hidden> -
STALE2002d
[PATCH v3 08/15] arm64: socfpga: merge Agilex and N5X into ARCH_INTEL_SOCFPGA
2021-03-11 · Krzysztof Kozlowski <hidden> -
STALE2028d
[RFC v2 3/5] arm64: socfpga: rename ARCH_STRATIX10 to ARCH_SOCFPGA64
2021-03-10 · Krzysztof Kozlowski <hidden> -
STALE2157d
[RFC PATCH 4/6] ethernet: m10-retimer: add support for retimers on Intel MAX 10 BMC
2020-10-23 · Xu Yilun <yilun.xu@intel.com> -
STALE2157d
[RFC PATCH 2/6] fpga: dfl: export network configuration info for DFL based FPGA
2020-10-23 · Xu Yilun <yilun.xu@intel.com> -
STALE2157d
[RFC PATCH 3/6] fpga: dfl: add an API to get the base device for dfl device
2020-10-23 · Xu Yilun <yilun.xu@intel.com> -
STALE2640d
[PATCH 37/39] docs: adds some directories to the main documentation index
2019-06-28 · Mauro Carvalho Chehab <mchehab+samsung@kernel.org> -
STALE2730d
REVIEWED: 1 (1M) [PATCH V3 3/7] mm/gup: Change GUP fast to use flags rather than a write 'bool'
2019-03-28 · <hidden> -
STALE2744d
[RESEND 3/7] mm/gup: Change GUP fast to use flags rather than a write 'bool'
2019-03-18 · <hidden>
Quiet for 30+ days
Patches with no review trailers and no replies. Either the author is heads-down elsewhere or these slipped through. Oldest first.
-
STALE142d
[PATCH 08/10] fpga: bridge: switch to using class_find_device_by_fwnode()
2026-03-23 · Dmitry Torokhov <dmitry.torokhov@gmail.com> -
STALE142d
[PATCH 09/10] fpga: manager: switch to using class_find_device_by_fwnode()
2026-03-23 · Dmitry Torokhov <dmitry.torokhov@gmail.com>