bitmap api · Maintained
Maintainers
- M Yury Norov <yury.norov@gmail.com>
- R Rasmus Villemoes <linux@rasmusvillemoes.dk>
Paths
- F
include/linux/bitfield.h - F
include/linux/bitmap-str.h - F
include/linux/bitmap.h - F
include/linux/bits.h - F
include/linux/cpumask.h - F
include/linux/cpumask_types.h - F
include/linux/find.h - F
include/linux/hw_bitfield.h - F
include/linux/nodemask.h - F
include/linux/nodemask_types.h - F
include/uapi/linux/bits.h - F
include/vdso/bits.h - F
lib/bitmap-str.c - F
lib/bitmap.c - F
lib/cpumask.c - F
lib/find_bit.c - F
lib/find_bit_benchmark.c - F
lib/test_bitmap.c - F
lib/tests/cpumask_kunit.c - F
tools/include/linux/bitfield.h - F
tools/include/linux/bitmap.h - F
tools/include/linux/bits.h - F
tools/include/linux/find.h - F
tools/include/uapi/linux/bits.h - F
tools/include/vdso/bits.h - F
tools/lib/bitmap.c - F
tools/lib/find_bit.c
Last 30 days
Recent patches
Most-recent 30 patches in this subsystem on netdev (capped at 30), ordered by date desc.
-
STALE79d
[PATCH v2 1/9] bitfield: add FIELD_GET_SIGNED()
2026-04-27 · Yury Norov <hidden> -
STALE82d
[PATCH 1/9] bitfield: add FIELD_GET_SIGNED()
2026-04-17 · Yury Norov <hidden> -
COLD30d
[net-next PATCH 04/10] bitfield.h: add FIELD_WIDTH()
2026-03-31 · Luiz Angelo Daros de Luca <hidden> -
STALE106d
[PATCH 4/8] core: use rest_of_page() macro where appropriate
2026-03-04 · Yury Norov <hidden> -
STALE100d
[PATCH v2 1/4] bitmap: introduce bitmap_weighted_xor()
2026-03-02 · Yury Norov <hidden> -
STALE138d
[PATCH RESEND 1/3] bitmap: introduce bitmap_weighted_xor()
2026-02-25 · Yury Norov <hidden> -
STALE136d
[PATCH 12/12] bitmap: drop bitmap_print_to_pagebuf()
2026-02-19 · Yury Norov <hidden> -
STALE136d
[PATCH 11/12] cpumask: switch cpumap_print_to_pagebuf() to using scnprintf()
2026-02-19 · Yury Norov <hidden> -
STALE136d
[PATCH 07/12] mm: add rest_of_page() macro
2026-02-19 · Yury Norov <hidden> -
STALE136d
[PATCH 06/12] bitmap: align test_bitmap output
2026-02-19 · Yury Norov <hidden> -
STALE136d
[PATCH 05/12] bitmap: switch test to scnprintf("%*pbl")
2026-02-19 · Yury Norov <hidden> -
STALE143d
[PATCH 1/3] bitmap: introduce bitmap_weighted_xor()
2025-12-23 · "Yury Norov (NVIDIA)" <yury.norov@gmail.com> -
STALE177d
[PATCH v2 11/16] bitfield: Common up validation of the mask parameter
2025-12-12 · <hidden> -
STALE177d
[PATCH v2 07/16] bitfield: FIELD_MODIFY: Only do a single read/write on the target
2025-12-12 · <hidden> -
STALE177d
[PATCH v2 03/16] bitmap: Use FIELD_PREP() in expansion of FIELD_PREP_WM16()
2025-12-12 · <hidden> -
STALE177d
[PATCH v2 13/16] bitfield: Reduce indentation
2025-12-12 · <hidden> -
STALE177d
[PATCH v2 05/16] bitfield: Merge __field_prep/get() into field_prep/get()
2025-12-12 · <hidden> -
STALE177d
[PATCH v2 14/16] bitfield: Add comment block for the host/fixed endian functions
2025-12-12 · <hidden> -
STALE177d
[PATCH v2 08/16] bitfield: Simplify __BF_FIELD_CHECK_REG()
2025-12-12 · <hidden> -
STALE177d
[PATCH v2 04/16] bitfield: Copy #define parameters to locals
2025-12-12 · <hidden> -
STALE177d
[PATCH v2 09/16] bitfield: Rename __FIELD_PREP/GET() to __BF_FIELD_PREP/GET()
2025-12-12 · <hidden> -
STALE177d
[PATCH v2 15/16] bitfield: Update comments for le/be functions
2025-12-12 · <hidden> -
STALE177d
[PATCH v2 12/16] bitfield: Remove leading _ from #define formal parameter names
2025-12-12 · <hidden> -
STALE177d
[PATCH v2 06/16] bitfield: Remove some pointless casts
2025-12-12 · <hidden> -
STALE177d
[PATCH v2 10/16] bitfield: Split the 'val' check out of __BF_FIELD_CHECK_MASK()
2025-12-12 · <hidden> -
STALE218d
[PATCH 8/9] bitfield: Add comment block for the host/fixed endian functions
2025-12-09 · <hidden> -
STALE218d
[PATCH 9/9] bitfield: Update comments for le/be functions
2025-12-09 · <hidden> -
STALE218d
[PATCH 6/9] bitfield: Update sanity checks
2025-12-09 · <hidden> -
STALE218d
[PATCH 3/9] bitmap: Use FIELD_PREP() in expansion of FIELD_PREP_WM16()
2025-12-09 · <hidden> -
STALE218d
[PATCH 4/9] bitfield: Copy #define parameters to locals
2025-12-09 · <hidden>
Quiet for 30+ days
Patches with no review trailers and no replies. Either the author is heads-down elsewhere or these slipped through. Oldest first.
-
STALE143d
[PATCH 1/3] bitmap: introduce bitmap_weighted_xor()
2025-12-23 · "Yury Norov (NVIDIA)" <yury.norov@gmail.com> -
STALE136d
[PATCH 05/12] bitmap: switch test to scnprintf("%*pbl")
2026-02-19 · Yury Norov <hidden> -
STALE136d
[PATCH 06/12] bitmap: align test_bitmap output
2026-02-19 · Yury Norov <hidden> -
STALE136d
[PATCH 07/12] mm: add rest_of_page() macro
2026-02-19 · Yury Norov <hidden> -
STALE136d
[PATCH 11/12] cpumask: switch cpumap_print_to_pagebuf() to using scnprintf()
2026-02-19 · Yury Norov <hidden> -
STALE136d
[PATCH 12/12] bitmap: drop bitmap_print_to_pagebuf()
2026-02-19 · Yury Norov <hidden> -
STALE106d
[PATCH 4/8] core: use rest_of_page() macro where appropriate
2026-03-04 · Yury Norov <hidden> -
STALE79d
[PATCH v2 1/9] bitfield: add FIELD_GET_SIGNED()
2026-04-27 · Yury Norov <hidden>