Re: [PATCH net-next v10 2/2] net: af_packet: Use hrtimer to do the retire operation

From: Xin Zhao <hidden>
Date: 2025-09-01 14:16:55
Also in: lkml

On Mon, 2025-09-01 at 09:35 -0400, Willem wrote:
quoted
On Sun, 2025-08-31 at 21:21 -0400, Willem wrote:
quoted
quoted
-		p1->retire_blk_tov = prb_calc_retire_blk_tmo(po,
-						req_u->req3.tp_block_size);
-	p1->tov_in_jiffies = msecs_to_jiffies(p1->retire_blk_tov);
+		p1->interval_ktime = ms_to_ktime(prb_calc_retire_blk_tmo(po,
+						req_u->req3.tp_block_size));
req_u is not aligned with the line above.
I have some questions regarding the alignment here. According to the alignment requirements,
req_u should be aligned below the po variable. However, if it is aligned below po, the line
will become very long, which may affect readability. In this special case, can I align it to
prb_calc_retire_blk_tmo instead, or should I continue to align it to the po variable?
The (minor) issue here is with the second req_u. Which is one space
off from the argument above. See checkpath.

In general, the line length and break rules are documented in the
kernel coding style page, which checkpatch follows.
quoted
What should I do next?
Should I change the alignment, and resend PATCH with the reviewed information of version 10?
I did not think this one space was worth resending, so I added my
Reviewed-by. Others may disagree, but so far no other opinions.
Okay, I will not resend the patch if there are no other opinions.


Thanks
Xin Zhao
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help