DORMANTno replies

[PATCH V2] net/802: use struct_size over open coded arithmetic

From: <hidden>
Date: 2022-02-10 06:08:55
Also in: lkml
Subsystem: networking [general], the rest · Maintainers: "David S. Miller", Eric Dumazet, Jakub Kicinski, Paolo Abeni, Linus Torvalds

From: "Minghao Chi (CGEL ZTE)" <redacted>

Replace zero-length array with flexible-array member and make use
of the struct_size() helper in kmalloc(). For example:

struct garp_attr {
    struct rb_node            node;
    enum garp_applicant_state    state;
    u8                type;
    u8                dlen;
    unsigned char            data[];
};

Make use of the struct_size() helper instead of an open-coded version
in order to avoid any potential type mistakes.

Reported-by: Zeal Robot <redacted>
Signed-off-by: Minghao Chi (CGEL ZTE) <redacted>
---
 net/802/mrp.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/net/802/mrp.c b/net/802/mrp.c
index 35e04cc5390c..880cb9ed9c4b 100644
--- a/net/802/mrp.c
+++ b/net/802/mrp.c
@@ -273,7 +273,7 @@ static struct mrp_attr *mrp_attr_create(struct mrp_applicant *app,
 			return attr;
 		}
 	}
-	attr = kmalloc(sizeof(*attr) + len, GFP_ATOMIC);
+	attr = kmalloc(struct_size(attr, data, len), GFP_ATOMIC);
 	if (!attr)
 		return attr;
 	attr->state = MRP_APPLICANT_VO;
-- 
2.25.1
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help