[PATCH] ath9k_hw: use swap() to make code cleaner

Subsystems: atheros ath generic utilities, qualcomm atheros ath9k wireless driver, the rest

STALE1748d LANDED

Landed in mainline as 22f9ba7fee10 on 2021-11-01.

2 messages, 2 authors, 2021-11-01 · open the first message on its own page

[PATCH] ath9k_hw: use swap() to make code cleaner

From: Yang Guang <hidden>
Date: 2021-10-28 01:05:02

Using swap() make it more readable.

Reported-by: Zeal Robot <redacted>
Signed-off-by: Yang Guang <redacted>
---
 drivers/net/wireless/ath/ath9k/ar9003_calib.c | 14 +++++---------
 1 file changed, 5 insertions(+), 9 deletions(-)
diff --git a/drivers/net/wireless/ath/ath9k/ar9003_calib.c b/drivers/net/wireless/ath/ath9k/ar9003_calib.c
index 7e27a06e5df1..dc24da1ff00b 100644
--- a/drivers/net/wireless/ath/ath9k/ar9003_calib.c
+++ b/drivers/net/wireless/ath/ath9k/ar9003_calib.c
@@ -1005,24 +1005,20 @@ static void __ar955x_tx_iq_cal_sort(struct ath_hw *ah,
 				    int i, int nmeasurement)
 {
 	struct ath_common *common = ath9k_hw_common(ah);
-	int im, ix, iy, temp;
+	int im, ix, iy;
 
 	for (im = 0; im < nmeasurement; im++) {
 		for (ix = 0; ix < MAXIQCAL - 1; ix++) {
 			for (iy = ix + 1; iy <= MAXIQCAL - 1; iy++) {
 				if (coeff->mag_coeff[i][im][iy] <
 				    coeff->mag_coeff[i][im][ix]) {
-					temp = coeff->mag_coeff[i][im][ix];
-					coeff->mag_coeff[i][im][ix] =
-						coeff->mag_coeff[i][im][iy];
-					coeff->mag_coeff[i][im][iy] = temp;
+					swap(coeff->mag_coeff[i][im][ix],
+					     coeff->mag_coeff[i][im][iy]);
 				}
 				if (coeff->phs_coeff[i][im][iy] <
 				    coeff->phs_coeff[i][im][ix]) {
-					temp = coeff->phs_coeff[i][im][ix];
-					coeff->phs_coeff[i][im][ix] =
-						coeff->phs_coeff[i][im][iy];
-					coeff->phs_coeff[i][im][iy] = temp;
+					swap(coeff->phs_coeff[i][im][ix],
+					     coeff->phs_coeff[i][im][iy]);
 				}
 			}
 		}
-- 
2.30.2

Re: [PATCH] ath9k_hw: use swap() to make code cleaner

From: Kalle Valo <hidden>
Date: 2021-11-01 14:20:17

Yang Guang [off-list ref] wrote:
Using swap() make it more readable.

Reported-by: Zeal Robot <redacted>
Signed-off-by: Yang Guang <redacted>
Signed-off-by: Kalle Valo <redacted>
Patch applied to ath-next branch of ath.git, thanks.

22f9ba7fee10 ath9k: use swap() to make code cleaner

-- 
https://patchwork.kernel.org/project/linux-wireless/patch/20211028010451.7754-1-yang.guang5@zte.com.cn/

https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help