# Re: \[PATCH\] nfp: Prefer struct\_size over open coded arithmetic

- From: Simon Horman \<hidden\>
- Date: 2021-09-13 08:31:52 
- List: netdev
- Page: https://ratatoskr.run/netdev/2021/09/1504959
- Thread: https://ratatoskr.run/netdev/2021/09/1504494/t.md

```text
On Sun, Sep 12, 2021 at 03:10:57PM +0200, Len Baker wrote:
> As noted in the "Deprecated Interfaces, Language Features, Attributes,
> and Conventions" documentation [1], size calculations (especially
> multiplication) should not be performed in memory allocator (or similar)
> function arguments due to the risk of them overflowing. This could lead
> to values wrapping around and a smaller allocation being made than the
> caller was expecting. Using those allocations could lead to linear
> overflows of heap memory and other misbehaviors.
> 
> So, use the struct_size() helper to do the arithmetic instead of the
> argument "size + count * size" in the kzalloc() function.
> 
> [1] https://www.kernel.org/doc/html/v5.14/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
> 
> Signed-off-by: Len Baker <redacted>

Reviewed-by: Simon Horman <redacted>

> ---
>  drivers/net/ethernet/netronome/nfp/nfp_net_repr.c | 3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)
> 
> diff --git a/drivers/net/ethernet/netronome/nfp/nfp_net_repr.c b/drivers/net/ethernet/netronome/nfp/nfp_net_repr.c
> index 3b8e675087de..369f6ae700c7 100644
> --- a/drivers/net/ethernet/netronome/nfp/nfp_net_repr.c
> +++ b/drivers/net/ethernet/netronome/nfp/nfp_net_repr.c
> @@ -499,8 +499,7 @@ struct nfp_reprs *nfp_reprs_alloc(unsigned int num_reprs)
>  {
>  	struct nfp_reprs *reprs;
> 
> -	reprs = kzalloc(sizeof(*reprs) +
> -			num_reprs * sizeof(struct net_device *), GFP_KERNEL);
> +	reprs = kzalloc(struct_size(reprs, reprs, num_reprs), GFP_KERNEL);
>  	if (!reprs)
>  		return NULL;
>  	reprs->num_reprs = num_reprs;
> --
> 2.25.1
> 
```
