From: Andy Shevchenko <andriy.shevchenko@linux.intel.com> Date: 2021-08-13 12:27:50
Eliminate some boilerplate code by using module_pci_driver() instead of
init/exit, and, if needed, moving the salient bits from init into probe.
Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
---
drivers/ptp/ptp_ocp.c | 20 +-------------------
1 file changed, 1 insertion(+), 19 deletions(-)
From: Andy Shevchenko <andriy.shevchenko@linux.intel.com> Date: 2021-08-13 12:27:52
Currently we are using BIT(), but GENMASK(). Make use of the latter one
as well (far less error-prone, far more concise).
Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
---
drivers/ptp/ptp_ocp.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)
From: Andy Shevchenko <andriy.shevchenko@linux.intel.com> Date: 2021-08-13 12:27:59
This makes the error handling much more simpler than open-coding everything
and in addition makes the probe function smaller an tidier.
Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
---
drivers/ptp/ptp_ocp.c | 40 +++++++++-------------------------------
1 file changed, 9 insertions(+), 31 deletions(-)
From: Jakub Kicinski <kuba@kernel.org> Date: 2021-08-13 18:14:12
On Fri, 13 Aug 2021 15:27:35 +0300 Andy Shevchenko wrote:
Eliminate some boilerplate code by using module_pci_driver() instead of
init/exit, and, if needed, moving the salient bits from init into probe.
Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
Jonathan has a series in flight which is fixing some of the same issues:
https://patchwork.kernel.org/project/netdevbpf/list/?series=530079&state=*
Please hold off for a day or two so it can get merged, and if you don't
mind double check at that point which of your patches are still needed.
According to patchwork your series does not apply to net-next as of
last night so it'll need a respin anyway.
Thanks!
From: Andy Shevchenko <hidden> Date: 2021-08-13 19:31:40
On Fri, Aug 13, 2021 at 9:15 PM Jakub Kicinski [off-list ref] wrote:
On Fri, 13 Aug 2021 15:27:35 +0300 Andy Shevchenko wrote:
quoted
Eliminate some boilerplate code by using module_pci_driver() instead of
init/exit, and, if needed, moving the salient bits from init into probe.
Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
Actually it may be the other way around. Since patch 2 in his series
is definitely an unneeded churn here, because my devm conversion will
have to effectively revert it.
According to patchwork your series does not apply to net-next as of
last night so it'll need a respin anyway.
I hope he will chime in and see what we can do the best.
--
With Best Regards,
Andy Shevchenko
From: Jonathan Lemon <hidden> Date: 2021-08-16 21:01:06
On Fri, Aug 13, 2021 at 10:30:51PM +0300, Andy Shevchenko wrote:
On Fri, Aug 13, 2021 at 9:15 PM Jakub Kicinski [off-list ref] wrote:
quoted
On Fri, 13 Aug 2021 15:27:35 +0300 Andy Shevchenko wrote:
quoted
Eliminate some boilerplate code by using module_pci_driver() instead of
init/exit, and, if needed, moving the salient bits from init into probe.
Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
Actually it may be the other way around. Since patch 2 in his series
is definitely an unneeded churn here, because my devm conversion will
have to effectively revert it.
quoted
According to patchwork your series does not apply to net-next as of
last night so it'll need a respin anyway.
I hope he will chime in and see what we can do the best.
I'm going to submit a respin of the last patch, I screwed something
up from all the various trees I'm using.
Please update to net-next first - the firat patch in your series
doesn't make any longer, given the current status.
--
Jonathan
From: Andy Shevchenko <hidden> Date: 2021-08-17 09:48:52
On Mon, Aug 16, 2021 at 02:01:01PM -0700, Jonathan Lemon wrote:
On Fri, Aug 13, 2021 at 10:30:51PM +0300, Andy Shevchenko wrote:
quoted
On Fri, Aug 13, 2021 at 9:15 PM Jakub Kicinski [off-list ref] wrote:
quoted
On Fri, 13 Aug 2021 15:27:35 +0300 Andy Shevchenko wrote:
quoted
Eliminate some boilerplate code by using module_pci_driver() instead of
init/exit, and, if needed, moving the salient bits from init into probe.
Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
Actually it may be the other way around. Since patch 2 in his series
is definitely an unneeded churn here, because my devm conversion will
have to effectively revert it.
quoted
According to patchwork your series does not apply to net-next as of
last night so it'll need a respin anyway.
I hope he will chime in and see what we can do the best.
I'm going to submit a respin of the last patch, I screwed something
up from all the various trees I'm using.
Please update to net-next first - the firat patch in your series
doesn't make any longer, given the current status.
I'll rebase my stuff on top of net-next and resubmit.
Thanks!
--
With Best Regards,
Andy Shevchenko
From: Andy Shevchenko <hidden> Date: 2021-08-17 12:43:20
On Tue, Aug 17, 2021 at 12:48:22PM +0300, Andy Shevchenko wrote:
On Mon, Aug 16, 2021 at 02:01:01PM -0700, Jonathan Lemon wrote:
quoted
On Fri, Aug 13, 2021 at 10:30:51PM +0300, Andy Shevchenko wrote:
quoted
On Fri, Aug 13, 2021 at 9:15 PM Jakub Kicinski [off-list ref] wrote:
quoted
On Fri, 13 Aug 2021 15:27:35 +0300 Andy Shevchenko wrote:
quoted
Eliminate some boilerplate code by using module_pci_driver() instead of
init/exit, and, if needed, moving the salient bits from init into probe.
Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
Actually it may be the other way around. Since patch 2 in his series
is definitely an unneeded churn here, because my devm conversion will
have to effectively revert it.
quoted
According to patchwork your series does not apply to net-next as of
last night so it'll need a respin anyway.
I hope he will chime in and see what we can do the best.
I'm going to submit a respin of the last patch, I screwed something
up from all the various trees I'm using.
Please update to net-next first - the firat patch in your series
doesn't make any longer, given the current status.
I'll rebase my stuff on top of net-next and resubmit.
Thanks!
It seems the driver disrupted so much that it requires much more work
to make it neat. New code looks like a custom MFD approach (WRT resource
management).
I have sent only patch 3 out of this series and have attached here the
problematic places in my opinion. Feel free to convert them to patches
with Suggested-by tag. But converting to MFD will make this driver much
much better to read, understand and maintain.
--
With Best Regards,
Andy Shevchenko