[PATCH] samples: bpf: add an explict comment to handle nested vlan tagging.

Subsystems: bpf [general] (safe dynamic programs and tools), the rest, xdp (express data path)

STALE1847d LANDED

Landed in mainline as d692a637b4c5 on 2021-08-10.

2 messages, 2 authors, 2021-08-10 · open the first message on its own page

[PATCH] samples: bpf: add an explict comment to handle nested vlan tagging.

From: Muhammad Falak R Wani <hidden>
Date: 2021-08-09 07:01:10

A codeblock for handling nested vlan trips newbies into thinking it as
duplicate code. Explicitly add a comment to clarify.

Signed-off-by: Muhammad Falak R Wani <redacted>
---
 samples/bpf/xdp1_kern.c | 2 ++
 samples/bpf/xdp2_kern.c | 2 ++
 2 files changed, 4 insertions(+)
diff --git a/samples/bpf/xdp1_kern.c b/samples/bpf/xdp1_kern.c
index 34b64394ed9c..f0c5d95084de 100644
--- a/samples/bpf/xdp1_kern.c
+++ b/samples/bpf/xdp1_kern.c
@@ -57,6 +57,7 @@ int xdp_prog1(struct xdp_md *ctx)
 
 	h_proto = eth->h_proto;
 
+	/* Handle VLAN tagged packet */
 	if (h_proto == htons(ETH_P_8021Q) || h_proto == htons(ETH_P_8021AD)) {
 		struct vlan_hdr *vhdr;
 
@@ -66,6 +67,7 @@ int xdp_prog1(struct xdp_md *ctx)
 			return rc;
 		h_proto = vhdr->h_vlan_encapsulated_proto;
 	}
+	/* Handle double VLAN tagged packet */
 	if (h_proto == htons(ETH_P_8021Q) || h_proto == htons(ETH_P_8021AD)) {
 		struct vlan_hdr *vhdr;
 
diff --git a/samples/bpf/xdp2_kern.c b/samples/bpf/xdp2_kern.c
index c787f4b49646..d8a64ab077b0 100644
--- a/samples/bpf/xdp2_kern.c
+++ b/samples/bpf/xdp2_kern.c
@@ -73,6 +73,7 @@ int xdp_prog1(struct xdp_md *ctx)
 
 	h_proto = eth->h_proto;
 
+	/* Handle VLAN tagged packet */
 	if (h_proto == htons(ETH_P_8021Q) || h_proto == htons(ETH_P_8021AD)) {
 		struct vlan_hdr *vhdr;
 
@@ -82,6 +83,7 @@ int xdp_prog1(struct xdp_md *ctx)
 			return rc;
 		h_proto = vhdr->h_vlan_encapsulated_proto;
 	}
+	/* Handle double VLAN tagged packet */
 	if (h_proto == htons(ETH_P_8021Q) || h_proto == htons(ETH_P_8021AD)) {
 		struct vlan_hdr *vhdr;
 
-- 
2.17.1

Re: [PATCH] samples: bpf: add an explict comment to handle nested vlan tagging.

From: patchwork-bot+netdevbpf@kernel.org
Date: 2021-08-10 09:21:07

Hello:

This patch was applied to bpf/bpf-next.git (refs/heads/master):

On Mon,  9 Aug 2021 12:30:46 +0530 you wrote:
A codeblock for handling nested vlan trips newbies into thinking it as
duplicate code. Explicitly add a comment to clarify.

Signed-off-by: Muhammad Falak R Wani <redacted>
---
 samples/bpf/xdp1_kern.c | 2 ++
 samples/bpf/xdp2_kern.c | 2 ++
 2 files changed, 4 insertions(+)
Here is the summary with links:
  - samples: bpf: add an explict comment to handle nested vlan tagging.
    https://git.kernel.org/bpf/bpf-next/c/d692a637b4c5

You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help