[PATCH] samples: bpf: xdp1: remove duplicate code to find protocol

Subsystems: bpf [general] (safe dynamic programs and tools), the rest, xdp (express data path)

STALE1822d

4 messages, 2 authors, 2021-08-09 · open the first message on its own page

[PATCH] samples: bpf: xdp1: remove duplicate code to find protocol

From: Muhammad Falak R Wani <hidden>
Date: 2021-08-08 12:24:54

The code to find h_vlan_encapsulated_proto is duplicated.
Remove the extra block.

Signed-off-by: Muhammad Falak R Wani <redacted>
---
 samples/bpf/xdp1_kern.c | 9 ---------
 1 file changed, 9 deletions(-)
diff --git a/samples/bpf/xdp1_kern.c b/samples/bpf/xdp1_kern.c
index 34b64394ed9c..a35e064d7726 100644
--- a/samples/bpf/xdp1_kern.c
+++ b/samples/bpf/xdp1_kern.c
@@ -57,15 +57,6 @@ int xdp_prog1(struct xdp_md *ctx)
 
 	h_proto = eth->h_proto;
 
-	if (h_proto == htons(ETH_P_8021Q) || h_proto == htons(ETH_P_8021AD)) {
-		struct vlan_hdr *vhdr;
-
-		vhdr = data + nh_off;
-		nh_off += sizeof(struct vlan_hdr);
-		if (data + nh_off > data_end)
-			return rc;
-		h_proto = vhdr->h_vlan_encapsulated_proto;
-	}
 	if (h_proto == htons(ETH_P_8021Q) || h_proto == htons(ETH_P_8021AD)) {
 		struct vlan_hdr *vhdr;
 
-- 
2.17.1

Re: [PATCH] samples: bpf: xdp1: remove duplicate code to find protocol

From: Yonghong Song <hidden>
Date: 2021-08-08 16:54:10


On 8/8/21 5:24 AM, Muhammad Falak R Wani wrote:
quoted hunk
The code to find h_vlan_encapsulated_proto is duplicated.
Remove the extra block.

Signed-off-by: Muhammad Falak R Wani <redacted>
---
  samples/bpf/xdp1_kern.c | 9 ---------
  1 file changed, 9 deletions(-)
diff --git a/samples/bpf/xdp1_kern.c b/samples/bpf/xdp1_kern.c
index 34b64394ed9c..a35e064d7726 100644
--- a/samples/bpf/xdp1_kern.c
+++ b/samples/bpf/xdp1_kern.c
@@ -57,15 +57,6 @@ int xdp_prog1(struct xdp_md *ctx)
  
  	h_proto = eth->h_proto;
  
-	if (h_proto == htons(ETH_P_8021Q) || h_proto == htons(ETH_P_8021AD)) {
-		struct vlan_hdr *vhdr;
-
-		vhdr = data + nh_off;
-		nh_off += sizeof(struct vlan_hdr);
-		if (data + nh_off > data_end)
-			return rc;
-		h_proto = vhdr->h_vlan_encapsulated_proto;
No. This is not a duplicate. The h_proto in the above line will be used
in the below "if" condition.
-	}
  	if (h_proto == htons(ETH_P_8021Q) || h_proto == htons(ETH_P_8021AD)) {
  		struct vlan_hdr *vhdr;
  

Re: [PATCH] samples: bpf: xdp1: remove duplicate code to find protocol

From: Muhammad Falak Reyaz <hidden>
Date: 2021-08-08 17:20:00

On Sun, Aug 8, 2021 at 10:23 PM Yonghong Song [off-list ref] wrote:


On 8/8/21 5:24 AM, Muhammad Falak R Wani wrote:
quoted
The code to find h_vlan_encapsulated_proto is duplicated.
Remove the extra block.

Signed-off-by: Muhammad Falak R Wani <redacted>
---
  samples/bpf/xdp1_kern.c | 9 ---------
  1 file changed, 9 deletions(-)
diff --git a/samples/bpf/xdp1_kern.c b/samples/bpf/xdp1_kern.c
index 34b64394ed9c..a35e064d7726 100644
--- a/samples/bpf/xdp1_kern.c
+++ b/samples/bpf/xdp1_kern.c
@@ -57,15 +57,6 @@ int xdp_prog1(struct xdp_md *ctx)

      h_proto = eth->h_proto;

-     if (h_proto == htons(ETH_P_8021Q) || h_proto == htons(ETH_P_8021AD)) {
-             struct vlan_hdr *vhdr;
-
-             vhdr = data + nh_off;
-             nh_off += sizeof(struct vlan_hdr);
-             if (data + nh_off > data_end)
-                     return rc;
-             h_proto = vhdr->h_vlan_encapsulated_proto;
No. This is not a duplicate. The h_proto in the above line will be used
in the below "if" condition.
quoted
-     }
      if (h_proto == htons(ETH_P_8021Q) || h_proto == htons(ETH_P_8021AD)) {
              struct vlan_hdr *vhdr;
Apologies :(
I now realize, it could be double vlan encapsulated.
Would it make sense to add an explicit comment for newbies like me ?
I can send a patch, if it is okay.

-mfrw

Re: [PATCH] samples: bpf: xdp1: remove duplicate code to find protocol

From: Yonghong Song <hidden>
Date: 2021-08-09 00:02:00


On 8/8/21 10:19 AM, Muhammad Falak Reyaz wrote:
On Sun, Aug 8, 2021 at 10:23 PM Yonghong Song [off-list ref] wrote:
quoted


On 8/8/21 5:24 AM, Muhammad Falak R Wani wrote:
quoted
The code to find h_vlan_encapsulated_proto is duplicated.
Remove the extra block.

Signed-off-by: Muhammad Falak R Wani <redacted>
---
   samples/bpf/xdp1_kern.c | 9 ---------
   1 file changed, 9 deletions(-)
diff --git a/samples/bpf/xdp1_kern.c b/samples/bpf/xdp1_kern.c
index 34b64394ed9c..a35e064d7726 100644
--- a/samples/bpf/xdp1_kern.c
+++ b/samples/bpf/xdp1_kern.c
@@ -57,15 +57,6 @@ int xdp_prog1(struct xdp_md *ctx)

       h_proto = eth->h_proto;

-     if (h_proto == htons(ETH_P_8021Q) || h_proto == htons(ETH_P_8021AD)) {
-             struct vlan_hdr *vhdr;
-
-             vhdr = data + nh_off;
-             nh_off += sizeof(struct vlan_hdr);
-             if (data + nh_off > data_end)
-                     return rc;
-             h_proto = vhdr->h_vlan_encapsulated_proto;
No. This is not a duplicate. The h_proto in the above line will be used
in the below "if" condition.
quoted
-     }
       if (h_proto == htons(ETH_P_8021Q) || h_proto == htons(ETH_P_8021AD)) {
               struct vlan_hdr *vhdr;
Apologies :(
I now realize, it could be double vlan encapsulated.
Would it make sense to add an explicit comment for newbies like me ?
I can send a patch, if it is okay.
This is not the first time people sending a patch trying to remove this
"duplicated" code. I think it is okay to send a patch with comments to 
say this is intended to handle nested vlan, so we can save everybody's 
time. Thanks.
-mfrw
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help