[PATCH net-next] pktgen: Use BIT(x) macro

Subsystems: networking [general], the rest

STALE1895d

2 messages, 2 authors, 2021-05-29 · open the first message on its own page

[PATCH net-next] pktgen: Use BIT(x) macro

From: YueHaibing <hidden>
Date: 2021-05-29 11:46:10

BIT(x) improves readability and safety with respect to shifts.

Signed-off-by: YueHaibing <redacted>
---
 net/core/pktgen.c | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/net/core/pktgen.c b/net/core/pktgen.c
index 3fba429f1f57..2915153458aa 100644
--- a/net/core/pktgen.c
+++ b/net/core/pktgen.c
@@ -218,10 +218,10 @@ static char *pkt_flag_names[] = {
 #define NR_PKT_FLAGS		ARRAY_SIZE(pkt_flag_names)
 
 /* Thread control flag bits */
-#define T_STOP        (1<<0)	/* Stop run */
-#define T_RUN         (1<<1)	/* Start run */
-#define T_REMDEVALL   (1<<2)	/* Remove all devs */
-#define T_REMDEV      (1<<3)	/* Remove one dev */
+#define T_STOP        BIT(0)	/* Stop run */
+#define T_RUN         BIT(1)	/* Start run */
+#define T_REMDEVALL   BIT(2)	/* Remove all devs */
+#define T_REMDEV      BIT(3)	/* Remove one dev */
 
 /* Xmit modes */
 #define M_START_XMIT		0	/* Default normal TX */
-- 
2.17.1

Re: [PATCH net-next] pktgen: Use BIT(x) macro

From: Jakub Kicinski <kuba@kernel.org>
Date: 2021-05-29 18:19:48

On Sat, 29 May 2021 19:45:59 +0800 YueHaibing wrote:
BIT(x) improves readability and safety with respect to shifts.
Some developers prefer not to use BIT(). I'm not applying these.
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help