# Re: \[PATCH net-next 03/14\] nexthop: Add a dedicated flag for multipath next-hop groups

- From: David Ahern \<hidden\>
- Date: 2021-03-11 15:54:35 
- List: netdev
- Page: https://ratatoskr.run/netdev/2021/03/11198311
- Thread: https://ratatoskr.run/netdev/2021/03/11198117/t.md

```text
On 3/11/21 8:39 AM, Petr Machata wrote:
> 
> David Ahern [ref] writes:
> 
>>> diff --git a/include/net/nexthop.h b/include/net/nexthop.h
>>> index 7bc057aee40b..5062c2c08e2b 100644
>>> --- a/include/net/nexthop.h
>>> +++ b/include/net/nexthop.h
>>> @@ -80,6 +80,7 @@ struct nh_grp_entry {
>>>  struct nh_group {
>>>  	struct nh_group		*spare; /* spare group for removals */
>>>  	u16			num_nh;
>>> +	bool			is_multipath;
>>>  	bool			mpath;
>>
>>
>> It would be good to rename the existing type 'mpath' to something else.
>> You have 'resilient' as a group type later, so maybe rename this one to
>> hash or hash_threshold.
> 
> All right, I'll send a follow-up with that.
> 

I'm fine with the rename being a followup after this patch set or as the
last patch in this set.
```
