# RE: \[Patch bpf-next v3 5/5\] sock\_map: rename skb\_parser and skb\_verdict

- From: John Fastabend \<john.fastabend@gmail.com\>
- Date: 2021-02-15 19:10:10 
- List: netdev
- Page: https://ratatoskr.run/netdev/2021/02/7760458
- Thread: https://ratatoskr.run/netdev/2021/02/7760432/t.md

```text
Cong Wang wrote:
> From: Cong Wang <redacted>
> 
> These two eBPF programs are tied to BPF_SK_SKB_STREAM_PARSER
> and BPF_SK_SKB_STREAM_VERDICT, rename them to reflect the fact
> they are only used for TCP. And save the name 'skb_verdict' for
> general use later.
> 
> Cc: John Fastabend <john.fastabend@gmail.com>
> Cc: Daniel Borkmann <daniel@iogearbox.net>
> Cc: Jakub Sitnicki <jakub@cloudflare.com>
> Reviewed-by: Lorenz Bauer <redacted>
> Signed-off-by: Cong Wang <redacted>
> ---

Acked-by: John Fastabend <john.fastabend@gmail.com>
```
