[PATCH] net: core: devlink.c: Hold devlink->lock from the beginning of devlink_dpipe_table_register()
From: <hidden>
Date: 2020-02-22 06:53:10
From: Madhuparna Bhowmik <redacted> devlink_dpipe_table_find() should be called under either rcu_read_lock() or devlink->lock. devlink_dpipe_table_register() calls devlink_dpipe_table_find() without holding the lock and acquires it later. Therefore hold the devlink->lock from the beginning of devlink_dpipe_table_register(). Suggested-by: Jiri Pirko <redacted> Signed-off-by: Madhuparna Bhowmik <redacted> --- net/core/devlink.c | 15 +++++++++++---- 1 file changed, 11 insertions(+), 4 deletions(-)
diff --git a/net/core/devlink.c b/net/core/devlink.c
index 3e8c94155d93..ba9dd8cb98c3 100644
--- a/net/core/devlink.c
+++ b/net/core/devlink.c@@ -6840,22 +6840,29 @@ int devlink_dpipe_table_register(struct devlink *devlink, { struct devlink_dpipe_table *table; - if (devlink_dpipe_table_find(&devlink->dpipe_table_list, table_name)) + mutex_lock(&devlink->lock); + + if (devlink_dpipe_table_find(&devlink->dpipe_table_list, table_name)) { + mutex_unlock(&devlink->lock); return -EEXIST; + } - if (WARN_ON(!table_ops->size_get)) + if (WARN_ON(!table_ops->size_get)) { + mutex_unlock(&devlink->lock); return -EINVAL; + } table = kzalloc(sizeof(*table), GFP_KERNEL); - if (!table) + if (!table) { + mutex_unlock(&devlink->lock); return -ENOMEM; + } table->name = table_name; table->table_ops = table_ops; table->priv = priv; table->counter_control_extern = counter_control_extern; - mutex_lock(&devlink->lock); list_add_tail_rcu(&table->list, &devlink->dpipe_table_list); mutex_unlock(&devlink->lock); return 0;
--
2.17.1